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Welcome to the Tournament Planner Help

Introduction

Since 1992 Visual Reality is developing software for the sport industry. These products are based on the
experience of many users, giving you plenty of optimized functionality. The Tournament Planner is used by
many organizations around the world and assists you with the organization of your tournament.

In this manual you will be guided through all the windows of the Tournament Planner. Every window is shown
and described in detail. The example tournament, that was used for making this manual, is called the Demo
tournament and is present at every installation of the Tournament Planner.

Good luck with organizing your tournament!

Important Information
Check the www.tournamentsoftware.com website often! You can download updates and keep in touch with the
latest developments.

If you are not familiar with Windows.

Being able to work with the Tournament Planner, some knowledge of the use of Microsoft Windows is required.
When working with the Tournament Planner, you will order windows regularly, make choices from popup-
menu’s etc.

The Tournament Planner makes use of the Office standard. If you are experienced in working with products of
Microsoft Office like Word, Excel or Outlook, you are able to work with the Tournament Planner right away. If
you have no experience at all with Windows, then it is advised to ask a handy neighbor or friend to help you
get to know the world called Windows.

1992-2016 Visual Reality. All rights reserved


http://www.tournamentsoftware.com
http://www.visual.nl

Installation

The installation of the Tournament Planner is very easy. You can run a new installation or you can update an
existing installation.

System Requirements

For the use of the Tournament Planner, you need a PC with at least Windows Vista. The Tournament Planner
works with all Intel Pentium processors, but like all the other programs the faster the better.

The Tournament Planner is working fine using Vista, Windows 7, Windows 8 and Windows 10. An Internet
connection is needed downloading updates, publishing, and online entry on the www.tournamentsoftware.com
website.

Required software:
Windows Vista/Windows 7/Windows 8/Windows 10

Minimum hardware:
e 1-gigahertz (GHz) processor

e 1 GB main memory
e 500 MB free hard disk space

New installation

For a new installation you need the Tournament Planner installation file and a license file. The license file is e-
mailed to you separately and the installation file can be downloaded from Tournamentsoftware.com.

If you double click the installation file, the installation will be started. Follow the instructions on the screen to

install the Tournament Planner. It is recommended to install the Tournament Planner in the standard folder.
You might have to restart the system after the new installation.

Updating an existing installation using Auto-Update

The auto-update function allows you to check for updates of the Tournament Planner. If any updates are
available they can be automatically downloaded and installed for you. Select Auto-Update in the tournament
overview or choose Help -> Check for updates in the main menu.

[{ Attention: You must have an internet connection to use the auto-update feature.

The Tournament Planner will now contact the website to check for any available updates.

Auto Update

] Cancel

Checking for updates

When updates are available they will be presented in a list showing you the version number and the size of the

P Vil Realily 7
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update. If you want to get the update, place a checkmark and click Download.

Aute Update X
Mame Version Size
Tennis Tournament Planner 2016.1 27,2MB

carel

The Tournament Planner will now download the update. Depending on the speed of your internet connection
this may take some time.

Auto Update

Downloading Tennis Tournament Planner

When the update is finished downloading the installation will be started. Follow the instruction on your screen in
order to complete the update. Your existing tournaments will be automatically converted to the new version.

[¥ Attention: You cannot open the updated tournaments in older versions of the Tournament Planner. Please
make sure all the machines are updated.

Updating an existing installation manually

If you already have an older version of the Tournament Planner installed, you can update the Tournament
Planner to the new version. You can update your installation by installing the full version of the Tournament
Planner found on the internet (www.tournamentsoftware.com).

[{ Attention: You can only run an update if you already have a license!
If you double click the installation file, the installation will be started. Follow the instructions on the screen to
install the Tournament Planner. It is recommended to install the Tournament Planner in the standard folder.

You have to restart the system after the new installation.

[{ Attention: You cannot use an older version of the Tournament Planner for reading the tournaments made
by a later version!



Windows Updates

Tournament Planner uses the latest technology. Some older versions of Windows do not have these
technologies. You can update your windows by installing the appropriate updates. In the online FAQ you can
find more information on how to update your Windows.

Register

If you get a message, while starting the Tournament Planner, explaining that it is a demo-version, it means
that the Tournament Planner is not registered yet.

Registration >

Demo "—-}

View the demo version or register.

You have installed version 2016 of this software, and your computer has a license for
version 2015 installed.

If you have received a new license you can register now.

If you do not have a new license you can order it online,
If you do not want to order a new license you can still install version 2015 of this software.

Click here to register your Tennis Tournament Planner
Register
Click here to order a license for Tennis Tournament Planner version 2016
Order
Click here to view the demo version of Tennis Tournament Planner

View Demo

Cancel Help

If you click on register, the Tournament Planner will ask you to select a license file. This file is sent to you by
e-mail and has the name of your organization (for example TC Demo.license).



Registration

Reqgistration

Please locate your license file,

License file

1. fou have received a license file in an e-mail.
2, Save the attached license file on your harddrive.
3. Use the [Browse] button to locate your license file.

Cancel ||

Help
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Getting started with the Tournament Planner

The Tournament Planner is very easy to use. The interface is easy and feels right, even to the inexperienced
Windows user. Important functions are accessible from the outlook bar and the shortcut keys are always
visible in the status bar.

Just in case you need help, you can find the help function under the F1 key as is the case in other Windows
programs.

You can start the Tournament Planner from the Start Menu or via the shortcut on the desktop. Start ->
Programs -> Visual Reality -> Tournament planner.

Creating a new tournament

Select Tournament -> New from the main menu. Give the new tournament a filename. After the tournament
file is saved the tournament properties are shown. All tournaments are created in the Default Tournament
Folder, so you can easily find them. You can set the Default Tournament Folder in the program Options
on the General tab.

Now you can enter a tournament name, which will be printed on all documents and used on the Internet.
Because tournaments can be on the Internet for more than one year it is wise to add a year extension to your
tournament name like 'Championships 2015'.

Opening a tournament
Select Tournament -> Open from the main menu. You can now select a tournament file; all tournament files
have the .tp extension. The Demo.tp file is an example tournament. Select a tournament and click Open.

[ Tip: Before you start working with the demo tournament, it is recommended to make a backup of this
tournament. In this case you can always go back to the old situation.



Import Schedule

Import Schedule

File -
Select the file to import from ? 'ﬁ

Browse

If you are running a large tournament you can schedule in a copy of the
tournament file. The schedule and offidals can be imported back into the
ariginal file,

Import Schedule
‘fou can select the day for which you want to impart the schedule.

Import Officials
The offidals assigned to matches throughout the day can be imparted.

< Back Finish Cancel Help

If you are running a large tournament you can prepare the schedule in a copy of the tournament file. To do
this you have to create a backup of the tournament and restore this backup on a second laptop. In the backup
tournament you can prepare the new schedule. When you are done you can import the new schedule in the

original tournament file by going in the main menu to Tournament -> Import Schedule. Click on

and select the tournament file you want to import.
It is also possible to import the officials assigned to matches. This can be done throughout the day.

Making a backup of a tournament

A backup is a compressed tournament file. Storing or emailing backups is more efficient than using
uncompressed tournament files.

Select Tournament -> Backup from the main menu. This will start the backup wizard. On the first page you
will see information of the Tournament you are creating a backup of.

7% Vinal Realily 12



Backup Wizard

File
Select the filename for the backup

Current Tournament

Tournament: Demo Tournament

Filename: |C:\Usersiyrobbert, VISLALLOCAL \Documents\Toernooien\Demo Toernooi, tp

Backup

Filename: |C:Ysersirobbert. VISUALLOCAL \Documents{Tournaments'\Backup| | Browse

Cancel Help

You can select the filename of your backup. To do this click the E] the button. Click Finish to create your

backup. When you need a copy of your tournament on another computer you can simply use the Restore
Wizard to achieve this.

[ Tip: Give the backup a clear name, so you can find it easily (for example: Backup of Demo Tournament.
tpbackup)



Restoring a tournament backup

Select Tournament -> Restore from the main menu. This will start the Restore Wizard.

Restore Wizard

File
Select the backup file of your tournament

Filename: |C:\Usersirobbert, VISUALLOCAL \DocumentsiTournaments \Backup «

< Back Mext = Cancel Help

On the first page you can select the backup file using the E] button. Click Next to continue.

14



Restore Wizard

File
Select the filename for this tournament

Filename: |C:Wsersirobbert. VISUALLOCAL \Documents{Toernocien\Demo. tp Browse

< Back Finish Cancel Help

On the second screen you can select the location and filename of your tournament. You can enter a new
filename or overwrite an existing tournament. Click Finish to restore the tournament from your backup file.
If a tournament exists with the same filename you will be asked if you want to replace the file.

7% Vinal Realily 15



Save As New Tournament
Save As New Tournament

File '
Select the new tournament file name, and the start date .' '

Mew Tournament File:

Browse
Mew startdate: | 1/ 3/2015 w
Delete All Players
< Back Finish Cancel Help

It is possible to save your tournament as a new tournament. This new tournament can be published on the
internet as a new tournament and doesn't overwrite the old tournament.

Tournament properties

Select Tournament -> Properties from the main menu.

[{ Attention: If you open the tournament properties of a more then 30 day old tournament the tournament
planner will give you the following warning:

7% Vinal Realily 16



Warning

I It is more than 30 days since the last day of this
s Bl tournament.

Please note that you need to start a new tournamentfile
for each tournament you run.

Otherwise your old tournament on the internet will be
owverwritten,

For each tournament you organize you need to start a new tournament file. Do not change an old tournament
into a new tournament. If you use a tournament file of an old tournament and publish the tournament to the
Internet, the old tournament will be overwritten.

Import Tournament Properties

Import Tournament Properties

File
Select the file to import from ? 'i

Tournament File:

Browse

|:| Organizer

[ ] address

[ ]Events

[ ] Times

[ ]Locations

|:| Entry Fee

|:| Extra Items

[ ] scoringformats
[ ] offidals

All Mone

< Back Mext Cancel Help

With Import Tournament Properties you are able to import the settings of an older Tournament. You got
the following options:

P Vil Reality 17



e Organizer
The organizer fields will be imported.

e Address

The entire address tab will be imported.
e Events

You can check one or more events you want to import.
o Times

The times will be imported only when the amount of days are the same as the older Tournament.
[# Attention: You cannot import any times when you did not create any dates yet.
o Locations
You can check the locations you want to import.
o Entry Fee
The calculation, type and currency will be imported.
o Extra Items
You can check the Extra Items one by one so you will keep an overview.
e Scoringformats
You can import the scoringformats when you use your own scoringformat.
o Officials
You can check one or more officials to be imported.

Click on Next to follow the rest of the instructions on screen to finish the import.

Info tab
Tournament Properties
Draws Score Officials
Info Address Events Days Times Locations/Courts Round Robins Entry Fees
Tournament Mame: |Demo Tournament Tournament Organizer:
Tournament Mumber: COroganizer Phone:
Dates: Organizer E-mail:
Weeknumber: Referee:
Draw Date: Referee E-mail:
Tournament Type: | Club Tournament ¥ Category (Youth):
Report logo;

Sponsor Banner:

Import Cancel

U can enter information about the tournament.

e Tournament Name
You can change the name of the tournament. Watch out: this name will be used on all printed documents
and will also be used if you publish your tournament on the Internet. Because tournaments can be on the
Internet for more than one year it is wise to add a year extension to your tournament name like
‘Championships 2015'.

¢ Tournament Number
You can enter the national tournament number, if your tournament has one.

o Dates, Week number, Draw Date and Location
This data is used on printed documents.

P Vil Realily 18



Tournament Organizer, Organizer Phone, Organizer E-mail:

This data is displayed on the Internet under Contact if you publish your tournament.

Referee and Referee e-mail:

You can enter the name of the referee and his e-mail address.

Category (Youth)

This is printed on the draw sheets.

Report Logo

You can select a picture which will be showed on printed draws and various other reports. You can show
your club logo or the logo of your sponsor..

Address tab
Tournament Properties
Draws Score Officials
Info i Events Days Times Locations/Courts Round Robins Entry Fees
Venue: Phane:
Address 1: Fax:
Address 2: Email:
Address 3: Website:
Postal code: Twitter:
City: |Alkmaar
State: |Moord-Holland
Country: | [ Metherlands v

Time zone: |{LUTC-+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienr w

Impaort Cancel

U can enter information about the location of the tournament.

Venue

The name of the location where the league will be held.

Address, PostalCode, City, State and Country

If you fill in the address of the venue, the address and a link to google maps is placed on the tournament
page.

Time zone

The time zone of the tournament's location.

Phone, Fax, Email and Website

You can enter the contact information and the website.

Twitter

Enter a username or hashtag to show the twitter feed on your tournament page.



Events tab

Tournament Properties

Draws Score Officials

Info Address Events Days Times Locations,/Courts Round Robins
Mame Gender Type Level Min  Max Fee

B ms Men Singles £ 25,00

=MD Men Doubles € 25,00

= WD Women  Doubles € 20,00

= ws Women Singles € 20,00

Import

Entry Fees
Pick
Add
Edit

Delete

Cancel

You can add, edit or delete the events of the tournament. Deleting events is only possible if there are no
entries or draw sheets for the event. Click Pick to select the events for your tournament from a pick list.

20



Events

Mame Gender Type Level Min  Max %
L] dms Men Singles

(13 ws Women  Singles

L] dm Men Dioubles

L[] 3wo Women  Doubles

[]dx Mixed Doubles

L[] = ms1 Men Singles 1

] 3 wsi Women  Singles 1

[] 9 mp1 Men Doubles 1

[ ] 3 w1 Women  Doubles 1

L] 31 Mixed Doubles 1

[ ] ms2 Men Singles 2

L] 3 ws2 Women  Singles 2

[] 9 mpz2 Men Doubles 2

[] 9 wp2 Women  Doubles 2

L] 9 xp2 Mixed Doubles 2

(] = ms3 Men Singles 3

1 3 wss Women  Singles 3 e

Fee: (0,00 Cancel

Check the events for your tournament. You can enter a Fee for the events, if any. Click OK to add the selected
events to the tournament.

To import events from a previous tournament use the Import button.

Click Add to manually add an event to your tournament. If you click on Add or Edit the Event Properties are
shown:

7% Vinal Realily 21



Event Properties

General | Scoring Format | Availability

-

A

i
Gender: | Men W
Type: | Singles L
Level: | <Mone:= W

Sep. Seeding: []

Min. Age: |0 =
May. Age: |0 =
Fee: |0,00

i || & Cancel Apply

For every event you can enter a name and change the set up:

e Gender
You can select: Men, Women, Mixed, Boys and Girls.

» Type
You can select: Single or Doubles.

e Level
You can fill in the level of the event.

e Sep. Seeding
If you want to have separate seedings in your main draw and qualification draws check this box. When
entering seedings on the entry properties you can have different seedings for your qualification and
main draw.

e Min. Age
The minimum age that is required for participating in this event.

¢ Max. Age
The maximum age that is required for participating in this event.

e Fee
The required fee for this event. This amount is used only when you have selected the option Sum of
event fees in the Tournament Properties.

e Scoring Format
For every event you can choose the scoring format. If the tournament default scoring format is not
adequate you can create a new one with appropriate settings on the Score tab.

During the tournament you will see the icon in front of the event name have different colors. These colors give
you an instant indication of the current status of the event.
¢ Gray
This event has no entries.
¢ Red
This event has entries but no draws.
e Orange
This event has at least 1 draw, but no players are in there.
e Yellow
This event has at least 1 draw but no matches have been scheduled.
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¢ Green
All matches have been scheduled.
¢ Blue
Some matches have been scheduled.
e Black
This event is finished, all results have been entered.

Days tab
Tournament Properties
Draws Score Officials
Info Address Events { Times Locations/Courts Round Robins Entry Fees
Add [sat 1/3/2015
1 Julhy 2014 k
HY sun 1/4/2015
Sun Mon Tue Wed Thu Fri Sat Delete FT]sat 1/10/2015

1

26 78] 3 1w 11 12

29113 14 15 16 17 18 19

020 21 2 23 4 25 %
|27 28 29 3 0N

203 4 5 & 7 8
[ Today: 7/8/2014

W Pl

Block previous week until: | 1/ 2/2015 w

You can add and delete Days from the tournament. Days can only be deleted if there are no matches planned
for that day.




Times tab

Tournament Properties

Draws Score
Info Address Events Days Times Locations/Courts
Times per day: |6 = Create 1Day Al Days
# # #3  #4 | £ | #6
Sat 1/3/2015 TENNE  10:15 11:30 12:45 14:00 15:15
Sun 1/4/2015 0%:00 10:15 11:30 12:45 1400 15:15
Sat 1/10/2015 0%:00 10:15 11:30 12:45 1400 15:15
Sun 1112015 0%:00 10:15 11:30 12:45 1400 15:15

Import

Officials
Round Robins

Copy

Entry Fees

Cancel

You can now set up the time slots. Firstly select the number of Times per day. Secondly fill in the times
manually or create them automatically by clicking one of the following buttons:

Click on the button 1 Day to create the times for the selected day.
Click on the button All Days to create the times for all days.

Times
Start Interval Stop Mr of Staggers  Stagger Interval
09:00 % | | 75 minutes w | | 2355 W 1 W 5 minutes W
Max, Times: |6 = (@) Replace () add
#1 |#2 |#3 |34 |#5 | #6
09:00( 10:15 11:30 12:45 14:00 15:15

Select a start time and an interval and press OK.
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Locations/Courts tab

Tournament Properties

Draws Score Officials
Info Address Events Days Times Locations,/Courts Round Robins Entry Fees
Location Courts Capadity Add
E Tennispark Alkmaar 4 26 it
E Tennispark Schagen 4 0 :
E Tennispark Schoorl 4 0 Delete
w

Spedfy available courts manually

On the Location/Courts tab you can define all the locations available. With the Add or Edit button the
location properties will open. On the General tab you can give the location a name and add the available

courts.



Location Properties

General | Address | Available Courts

% Tennispark Schagen

Court Create

|E| = Add
FE Edit

Delete

Mawve Lip

Mawve Down

o] oot

With the Move Up and Move Down buttons you can change the order of the courts.
Create Courts

You can click Create to define all the courts available. Select how many courts you want to create and if you
want to give the courts a prefix.

Create Courts

How many courts do you want to create? |4
Do you want a prefix for each court?

(®) Numbers

) Letters

1,2, 354
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With the Add or Edit button the court properties will open. On the General tab you can give the court a name.

Court Properties
General | Availability
anl
- |
Location: Tennispark Schagen

i || ¥ Cancel Apply

On the Availability tab you can fill in when the court is available. This will only have effect when calculate
from availability per court is set on the Location/Courts tab

In the matrix you can fill in the availability of the court. Click with the mouse on the matrix to activate it. Now,
you can move the cursor with the cursor keys. The availability can be blocked by using the space bar (the red
blocks) and you can make the court available with the Delete button. With the Copy from button you can
copy the availability from other courts.
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Court Properties

General | Availability

15 30| 60 Mot available Copy from
o R e T = T R I S S U P I PR Y Y T % % |
v bl e bl Bl el ol B e e el bl el e el
[ o DO o (R s Y e T s Y e I s A o O o I o (O o T o (O o R o R o B o |
o o o O o O o o o o o o o O o O

Sat 1/3/2015
Sun 1/4/2015
Sat 1/10/2015
Sun 1/11/2015

i || & Cancel Apply

[{ Tip: You can use the left mouse button to select multiple blocks at the same time.
[ Tip: Select a date to change the availability for a whole day at once.

With the buttons above the matrix you can adjust the size of the time blocks. You can set it to 15, 30 or 60
minutes. The Tournament Planner always stores the availability in 15 minute blocks so there is no information

lost if you switch between 15 and 60 minutes. This also makes it possible to have half or quarter filled blocks in
the 60 minutes mode.

On Address tab you can fill in the location address:
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Location Properties

m Address | Available Courts

Address: ||

PostalCode:

City:

Country: =Mone = W |

|
|
State: |
|
|

Phone:

o || cwen || o

If you select Specify available courts manually on the Location/Court tab you can set the number of
available courts on the Available Courts tab:
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Location Properties

General | Addresz | Available Courts

09:00 10:15 11:30 12:45 1400 15:15
sat 1/3/2015 M

Sun 1/4/2015

Sat 1/10/2015

Sun 1/11/2015

Available courts: 4 | This Day All Days Copy

Using the button This Day, you can fill in the available courts for the selected day.
Using the button All Days, you can fill in the available courts for all days.
Using the Copy button you can copy the available courts of the selected day to the other days.
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Round Robins tab

Tournament Properties
Draws Score Officials
Info Address Events Days Times Locations,/Courts Round Robins Entry Fees
Standi Calculation:
Scoring: | Points Per Match nings Lalcuiation
Rules Mave Up

Points Per Match
Match wan = Match-Points

Relative Match-Points

Match draw L Relative Set Difference

Match lost ] = Relative Game Difference

Do not use results of retired players
[ | set Difference

[ | Game Difference

|:| Games For

[] Head To Head

[] set Percentage

[ ] Game Percentage

Mowe Dawn

4

3

4

3

[ Mo loser points for walkovers

Impart Cancel

The standings are calculated by rules. These rules may differ for certain tournaments, sports or countries.
You can select two types of scoring. You can set the scoring to Points per Match, Points per Set or Points
per Game.

e Points per Match
You can define how many points a win, loss or draw will get.

o Points per Set
You can define how many points a player get for a set won with one, two or more then three game(s)
difference.

Scoring: | Points Per Set -

Paints Per Set

Setwon 3+ 2 =
Set won 2 2 =
Setwon 1 3 =
Set draw 1 |=
Setlost 1 1 =
Setlost 2 0=
Setlost 3- 0=

You can also define this for a draw and the player that lost the set.

¢ Points per Game
For every game won you get one point.
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The rules for the Standings Calculation can be enabled and disabled and the order can be changed. The
current setup is the most used one.

Entry Fees Tab

Tournament Properties
Draws Score Officials
Info Address Events Days Times Locations,Courts Round Robins Entry Fees
Calculation Extra [tems
(@) Based tr
= ased on entry Mame Fee Add
() Based ticipati
—/ Based o particpaton \ZF T-Shirt £15.00 _
Edit
Type: |Sum Of Event Fees W Delete
Move Up
Maowve Dawr
Currency: | Other W

Impaort Cancel

You can select which events are used for the calculation:
e Based on entry
All the events the players have registered for are used for the calculation. This setting is useful when
your tournament is still accepting entries.
e Based on participation
Only the events where players are actually in a draw are used for the calculation. This setting is useful
after you have made your draws.

You can select in which way the fee for each player is calculated.

¢ Sum of Event Fees
The total entry fee of a player is the sum of the entry fee of the events the player has entered. You
can enter an event fee in the Event Properties.

¢ Number of Events
You can fill in what the costs are for the first, second and third event. For instance it's possible to make
the entree fee for the first event higher because there is a T-shirt present included. You can then make
the second event cheaper.
The entry fee is calculated from the number of events the players has entered. The costs can be
indicated on this screen.

[{ Attention: When the calculation is Based on participation the entry fee of a player can be 0 as long as
he is not in a draw of the event.

Besides the entry fee, you can also register other ordered items with each player. Click Add to open the
properties for an new item.
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Extra ltem Properties

General

ﬁ |T-Shirt |

Type: YesiMo W

Fee: [15.00

Mandatory:

You can name up the article and their price. At type you can choose what will be displayed on the tournament
entry page on tournamentsoftware.com.

Number:

The player can set the amount of items by picking a number from a list.

Text:

The player can fill in a text.

Yes/No:

The player can choose if he wants the item.

Mandatory:

If you tick mandatory the extra item must be purchased to be able to enter the tournament.

For the players, who are not using tournamentsoftware.com to enter a tournament, the extra items can be
filled in on the player properties. The costs will be added to the fee.

[# Attention: Do not use the Extra items for events



Draws Tab

Tournament Properties

Info Address Events Days Times LocationsCourts Round Robins Entry Fees

Draws Score Officials
[ ] show match numbers in draws Showe arder of play arid
[ ] show duration in draws Showe round numbers in round robins
Show seeds in bold font [ ]Balance home and away in round robing
Show bye numbers 30 = minutes break after match
[ ] show court in draws Mixed Doubles Order

i Unchanged

[ ] show location in draws -
() Wamen First

Show partners alphabetically ~
@ Men First

[ ] chedk Offical Neutrality

Check-In: | Per Match (¥

Impart Cancel

You can select some general settings for your draws on this tab.

¢ Show match numbers in draws
This option allows you to show the match numbers in the draws.

e Show duration in draws
This will show the duration of the matches after the result.

e Show round numbers in round robins
When scheduling round robins it is always hard to determine the optimal playing schedule. Tournament
Planner can come up with such a schedule for you. For example: a size 10 round robin can always be
played in 9 rounds, but it can be difficult to figure this out yourself.

e Show seeds in bold font
This option allows you to show seeds player in bold font.

¢ Show bye numbers
This option allows you to show the bye numbering in the draws.

e Show order of play grid
The order of play is an alternative way of scheduling matches. Rather than scheduling on a specific
time, matches are scheduled using the 'followed-by' system.
When this option is ticked you will get an extra screen on the main window where you can see a grid of
all the courts and drag matches on there.

e Show location in draws
When this option is ticked the location of the scheduled matches is displayed in the draws.

e Check-In
You can set if the players have to check in per match or per day.

e Balance home and away in round robins
The home and away matches are evenly divided.

e Minutes break after match
When a match has ended a watch will appear behind the names of the players displaying the
remaining rest time.

e Mixed doubles order
If you always want to see the mixed doubles in the same order you can make your selection here.
When 2 partners are linked the order is automatically corrected for you.
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Score Tab

Tournament Properties
Info Address Events Days Times Locations/Courts Round Robins Entry Fees
Draws Score Officials
Mame Add
+ Standard (Default) Edit
Delete
Set Default

Auto complete scores

On the Score tab you can edit the default scoring format or create a new one. Check the auto complete box to
automatically complete the scores when typing. This will help you in more than 90% of the scores. You can
change the score to be filled in for the opponent. In less than 10% you will need to adjust the score of the
opponent. Click on Add or Edit to open the Score Format properties.
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Scoringformat Properties

General
Standard
Best of: | 3 =
Set Type: Mormal (Tie-break at 6-8) W
Last Set: Long Set (Mo Tie-break) v

o | sorh

On the General tab you can give the Scoringformat a name, set the Best of, Set Type and Last Set.



Officials

Tournament Properties
Info Address Events Days Times Locations/Courts Round Robins Entry Fees
Draws Score Officials

Mame Country  State Add

fid Official 1 NED =

i} offical 2 5CO
Delete
Import

With the Add or Edit button the official properties will open. Here you can fill in the names, nationality and the
function of the umpire.
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Official Properties

General

i

Last Mame:

First Mame:

State:

Country: <Mone = W

StartDate: | 7/ 5/2014 W
End Date: | 7/ /2014 W

Function:

£

o || cmet || o

With the Import button you can import officials from an excel or Dbase file:
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Import

File
Select the file to import from

This wizard allows you to import several file types:

Excel files
Make sure the data is on the first sheet and the first row contains the field names.

< Back Mext Cancel Help

Income and expense

Select Tournament -> Income and Expense from the main menu. You can keep track of all your
tournaments income and expenses. On the Income tab you can fill in all your income. Click Add to add an
extra line. Specify a description and an amount. Double click a line to change the description or the amount.

Click Delete to delete the selected line.
On the Expenditure tab you can do the same for all your tournaments expenses.
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Income and Expenditure

Income | Expenditure

Title Amount
Lottery €1,500.00
Main Sponsar €3,500.00
Add Delete Total:  €5,000.00
Print Close

Click Print to print a report of your income and expenses.

Deleting a tournament

A tournament is saved in a tournament file. Deleting the tournament is as simple as deleting the tournament
file. All tournament files have the .tp extension.
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Working with the Tournament Planner

After you have created your tournament, you can really start working with the Tournament Planner. You can
now enter players, make rosters, draws and plan matches. With the Tournament Planner you can work with
more than one tournament. The name of the currently opened tournament is displayed in the title bar of the
Tournament Planner; in this case it is the tournament ‘Demo Tournament’.

{ "3" Tennis Tournament Planner - Demo Tournament |E@|é”

The relevant shortcuts are always displayed in the status bar on the bottom of the Tournament Planner next to
your registration. By using these shortcuts you can directly execute an action without using the mouse.

U Visual Reality [Enter] Score [FG] Show Match [F7] Schedule [F2] Find Player In Draw [F10] Player Matches [F12] Change Partner U

The Tournament Planner has different views for the tasks of managing a tournament. A different view can be
selected by clicking on the buttons on the Outlook bar on the left.

Tournament
v@ On the Overview view you can find all sorts of information about the current tournament.
Overview
W On the Players view all the data of the players of the tournament are being kept. Here
you can enter personal data, select events and fill in the availability of the player.
Players
]
ﬂ On the Roster view you can classify the players and create the draw sheets.
Roster
g} On the Draws view you can view all the draw sheets, make draws and plan matches.
Draws
Q
On the Matches view you can see an overview of all the matches.
Matches
u On the Notes view you can view, create and edit notes.
Motes
:]_LJ On the Messages view you can see all your messages. You can create messages on
several places in the Tournament Planner
Messages

Below you will find an explanation of the different views you get by using the buttons on the Outlook bar.



Overview

By clicking the Overview button on the left, you will enter the Overview view where you can find all sorts of
information of the current tournament.



Tournament tab

Tournament

3

Owerview

&

Players

Messages

Player Draw Report |nternet Messages

)

Tournament  Court Usage Statistics  Schedule

?—J Tennis Tournament Planner - Demeo Tournament

NEHRFS =222

Extra Help

_—
/ Tournament Planner

Demo Tournament

Pick a Task

Set your tournament properties
Add players to your tournament
Add drawsheets

Make draws

View draws

View all matches

Publizh this tournament on the
wehb!

Information

Check for updates
Automatically check for an update.

Version 2016.1 01-jan-2016 08:31
Installation path:

ChProgram Files (x86)\Visual
Realiy\ TTP 20161 EMY

Support

Help
Find answers to your questions,

www tournamentsoftware.com
Check our website for the latest
VErsion

Suggestions for additional features are

welcome!

Tournament

File: Ch\UsersrobberthDocuments Toernooien' Demo Tournament EMN

Date: 16 - 22 mrt 2013

Published: di 2-9-2014 16:40

22

Players

4

Courts

79%

Scheduled
Fees
Total Fee € 430,00
| TS + & 0 Y

31

Entries

7

Days

4%

Completed

24

Match

In the Information group you will find the Tournament Planner version and the installation path. With the

Check for updates you can automatically check for updates. In the Support group you can open the help or
visit the website.
If you have not opened a tournament then Pick a Task will enable you to open a tournament or you can
create a new one.
If you have opened a tournament then you can pick one of the following tasks:

P Vil Reality
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Set your tournament properties
Add players to your tournament
Add draw sheets

Make draws

View draws

View all matches

Publish this tournament on the web!

The tournament tab gives you an overview of the structure of the tournament. You can find information about:

Tournament

The location of the tournament file and the tournament director.

Fees

The total amount of entry fees and the ordered items

Events

Here you can find the created events. If you want to change these events click Edit Events.
Days

Here you can find all the created days. If you want to change these days click Edit Days.
Courts

Here you can find all the courts, available or not. If you want to change these courts click Edit Courts.
Birthdays

Here you can find all players of with their birthday today, so you can congratulate them.
Information

Here you can find information about the number of players and the number of entries.

[# Tip: By clicking on the tournament file the location of the tournament will open in the explorer.



Court Usage tab

Tennis Tournament Planner - Demo Tournament

RN

curnament Player Draw  Order of play Report  Internet  Messages Extra  Help
IEHHTFISI =2 88508

@

Tournament | Court Usage | Statistics | Schedule

Owverview
Location: Al v [l Mo courts All courts used Over capacity
@ Capadty:36 g B 5 =R 2 G
Used: 6 = R R
Players el Ll e Ll el
- Sat 1/3/2015 0 000000
= Suni/42015 5 2 0 2 10 0
Roster Sat 1/10/2015 1 00 1000
Sun 1112015 o0 000 0o
Draws
=l
I <
Order of play
Used /Free
Q )
Matches 3]
L3 y
Motes
Bd || ]
Messages I | . |
09:00 10:15 11:30 12:45 14:00 15:15

The Court Usage tab gives you an overview of the number of available courts during the day. The button
Used shows the number of planned matches per time and the Free Button shows you the number of available
courts on every time. After the day you will also see the daily total.

The following colors are used:
e Black

This time has no courts available for scheduling
e Green

All courts on this time have been used
e Red
There have been planned to many matches for the amount of available courts

You can set the number of courts per time slot in the Tournament Properties.
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The court capacity graphic displays for each moment of the day the court capacity and how many courts are
used. The blue line indicates the court capacity, a blue block indicates how many courts are used, a green
block indicates that the court capacity is reached and when the court capacity is exceeded the graphic displays
a red block

With the location filter you can see the capacity for each location separately

Statistics tab

7] Tennis Tournament Planner - Demo Tournament
To

urnament Player Draw  Order of play Beport |Internet Messages Extra  Help

IEHEFSe= 82808

@ Tournament | Court Usage | Statistics | Schedule

Overview

Event Entries Mot Entered Entered Matches Mot Schedu... Played ‘Walke
@ B Ms 8 2 5 16 10

3 ws 0 0
Flayers 3 MD a0 a0
=l WD u] u]

a Total 15 10

L e R e R o
[ S e e
Lo U e R e R
o oo o o o

=l
|=rs

Order of play

Q

Matches

[j

Motes

3

Messages
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The Statistics tab gives you an overview per event and a total of the following data:

The
The
The
The
The
The
The
The
The
The
The

number of entries.

number of not entered players.

number of entered players.
number of matches.

number of matches yet to plan.

number of played matches.
number of walkovers
number of played sets
number of played games
number of minutes
average number of minutes
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Schedule tab

Tennis Tournament Planner - Demo Tournament

I—|~nl|":\.‘l

curnament Player Draw  Order of play Report  Internet  Messages Extra  Help
NEHREHTFI =282

@ &9

Tournament | Court Usage | Statistics | Schedule
Overview

Event 03/01 04/01 10/01 11/01 NotS...  Total

@ B ms 5 1 10 16

= ws
Players = MD

3 wD
a Total 5 1 10 16

H
|I.";

Order of play

Matches

Messages

The Schedule tab gives you an overview per event per day how many matches have been scheduled.

Players

By clicking left the Players button you will enter the Players view where you can edit all the data of the

players of the tournament. Here you can enter personal data, select events and fill in the availability of the
players.

Click the button Add Player to add a new player to this tournament. You can delete a player by clicking
Delete Player.

[ Tip: If you are using Online Entry, all the data will be automatically filled in when you pick up your online
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entries.

General tab

7] Michael Dekker Properties
Fee MNote Messages
General Address Sport Events Availability

& -

Last Mame: |Dekker

First Mame: |Michael
Middle Marme:
Gender: | Male W
Date of Birth: | 7/1/1968

Member ID:

Club: | gl Club 1 "
Entry Date: | 3/18/2014 [E~

Entry Method: | Manual W

On the General tab you can enter the most important data of the player. You can select the club from the pick

list. If a particular club is not listed, you can click the E] button and add it.
The memo field allows you to make notes for a player.
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Adding a club

Clubs

Clubs | Districts

Find;

Club

@Akers]uut
@.ﬁ.]lm‘laar
@Aﬂna Paulowna
@Ealdmm
@Eeemsmr
@Eergen
@Eundspas
GUBSY
@Castricum

%1 DEM
@Egmund
@Fesﬁna
@Gruutslag
@Heerenduinen

@Heerhuguwaard
A

ID District

Players

I = = T = T s TR O e T e Y e Y s TSP e O Y e S o T

m

[ vew ][ ea

&
[Iw}
m

S

g
i
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r

Club Properties ﬁ1
General
gh Alkmaar
District: |2 Amsterdam -
Club ID:
[ Ok, ” Cancel H Apply

e

If you want to search for a club you can type in the first letters of the name of the club in the Find field.
Click on New if you want to add a new club. On the Club Properties dialog you can enter a club name and
club ID and select a district. If you want to delete a club, select this club and click Delete.

It can happen that one certain club is added in the list with two different names. In that case, you can merge
these clubs. Select the club with the correct name and click on the Merge button. Now select the club where
the players have to be replaced and click OK. All players are now replaced and the old club is deleted.

51



Districts

Do you want to add or delete districts? Then click on Districts tab. You will get a list with all the current
districts.

Clubs |
Districts
Find:
District Code i |
wh Amsterdam AMS
wk Brabant Oost BRO
d Den Haag DMH
# Drenthe DRE
rk Endhoven EHV
i Frizsland FRL =
wh Gelderland GLD
d Groningen GRO
w Haarlem HRL
7 Leiden LEI
vk Limburg LIM
h Midden Brabant MER. I
7 Noord Holland Noord MHM
il Overijssel OVE
w Rotterdam ROT
I I TR S S e i
’ Mew ] ’ Edit ] ’ Delete ]
o ][ cnm




[ District Properties ﬁ
General
a Amsterdam
Code: AMS
[ (0]4 ] ’ Cancel ] ’ Apply

A district can be added by clicking New and a selected district can be deleted by clicking Delete. On the
Districts Properties dialog you can enter a name and a code. The code is used on reports.
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Import Clubs
Select Player -> Import Clubs from the main menu.
Click on to select the Dbase or Excel file you want to import. Click Next to link the fields.

rImpDr't |i|1
Id
ne F‘IZase select the fields to link to ? i
v

CubID: | -

Club: [ v]

District ID: | -

District: | -

« Back “ Mext = ] ’ Cancel ] ’ Help

Now you can link the fields of your import file to the fields of the Tournament Planner. The Tournament Planner
will try to create a link automatically using the fieldnames.

Fieldname: |Is linked to:
Club ID Club ID

Club Club

District ID District Code

District District

You can link the missing fields by hand. If not all data are present in your Dbase file, then they won't either
appear in the member file of the Tournament Planner. Click on Next to continue.

The result is shown. Now you can check if the right data is filled in the right fields. You can go back to make
changes if necessary. Click on Next to import the clubs in to the tournament.

Export Clubs

You can export the clubs in the tournament to an Excel file. Select Player -> Export Clubs from the main
menu and specify the filename.
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Contacting players

It is important that you can contact players quickly and easily. The Tournament Planner offers a couple of
possibilities.

Email

If you know the email address of a player, then you can also send an email message. Click on the button Mail

Players or select from the main menu Player -> Send Players Email. In that case you will get the next
window:

First Match E-mail

E-mail

Subject:

Dermo Tournament

Header:

Here comes the event and first matches of the player
Show court
Footer:

Send Cancel

On the Email tab you can create your message. You can enter a Subject. By default the Subject has the
tournament name filled in, but of course this can be changed. In the field Body you can type the message.

On the Players tab you can select the players to whom you want to send this email. You can select all players
by clicking All, clicking None will deselect all players.

If you are ready you can click Send to actually create the message. All messages will be saved in the

messages view ready to be sent. In order to send e-mail messages you must specify your e-mail settings in
the program settings.



SMS

If you know the mobile number of a player, then you can also send a SMS message. Click on the button SMS
Player or select from the main menu Player -> Send players SMS and it will open the message window:

%  SMS Players (0 characters) — [
SMS

Subject:
Dermo Tournament

Body:

Send Close

In the Body field you can fill in the SMS message with a maximum of 160 characters. If you are ready you can
click Send to actually create the message. All messages will be saved in the messages view ready to be sent.
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Address tab

7]
Fee
General

Address;

PostalCode:
City:

State:
Country:

Phone Home:

Phone Office:
Maobile:

Email:

Michael Dekker Properties
Mote Messages
Address Sport Events Availability

Demo address

123448
Alkmaar

Moord-Holland

= Metherlands W

Cancel Apply

On the Address tab, you can fill in the contact information of the player. If you fill in a mobile number it's

possible to sent the player a SMS. If you fill in an email address it's possible to sent the player an email.
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Sport tab

17 Michael Dekker Properties
Fee MNote Messages
General Address Sport Events Availability

Rating 5/D:
Ranking 5/D:

Points 5/0:

On the Sport tab you can specify the level, rating and rankings of the player. The rankings can also be

imported using the menu option player, Import ranking.
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Events tab

17 Michael Dekker Properties
Fee Mote Messages
General Address Sport Events Availability

v
W3
MD
WD

Partner: “Maone =

On the Events/Availability tab you can select the events where the player wants to participate in. If it
concerns a doubles event you can directly select the partner on the bottom. Make sure the right event is
selected before choosing the partner. If player A is selected as a partner for player B, then player B will
automatically be selected as a partner for player A. You can also select Partner Wanted as a partner. This
reminds you the player is still looking for a partner.

[ Tip: You can also select the partner on the Roster tab.
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Availability tab

L7 Michael Dekker Properties
Fee Mote Messages
General Address Sport Events Awvailability
15 30 | &0 Mot available Partner not available
Partner: “Mone = W
O O O = = = = = =~ = =~ = =~ [} [
=l 00 O O = kL) N = 00 O O
cooo o oo oooDoooooo
o o o O o O o O O o o O o o o

Sat 1/3/2015
Sun 1/4/2015
Sat 1/10/2015
Sun 1/11/2015

< >

[ ]Plays tournament in previous week

i || & Cancel Apply

In the matrix you can fill in the availability of the player. Click with the mouse on the matrix to activate it. Now,
you can move the cursor with the cursor keys. The availability can be blocked by using the space bar (the red
blocks) and you can delete them with the Delete button.

[ Tip: You can use the left mouse button to select multiple blocks at the same time.
[{ Tip: Select a day-name to change the availability for a whole day at once.
[ Tip: After selecting a block you can also change the availability with the right mouse button.

With the buttons above the matrix can adjust the size of the time blocks. You can set it to 15, 30 or 60 minutes.
The Tournament Planner always stores the availability in 15 minute blocks so there is no information lost if you
switch between 15 and 60 minutes. This also makes it possible to have half or quarter filled blocks in the 60
minutes mode. When a player has scheduled matches they will show up here by showing you an icon of a ball
or shuttle.

In the case of a double event the availability of the partner is displayed in pink. When a player has more then
one partner, you can use the Partner drop down menu to switch between them.



Fee tab

17 Michael Dekker Properties
General Address Sport Events Availability
Fee Mote Messages
Extra Items
Mame Value Fee

= T-shirt

Extra Items: €0.00
Entry Fee: £25.00
Total Fee: €25.00
Discount: 0.00
Payments
Date Type Amount
Add Delete Paid: €0.00

Receipt Balance Due: € 25 . ﬂu

During the tournament you can see on the Fee tab how much the player has payed and how much he still has
to pay. In the Tournament Properties on the Entry Fees you can specify if the calculation of the fee is
based on entry or participation.

You can place and specify the number of any ordered item. In this example we can select if the player wants to

buy a T-shirt.
To add the T-shirt double click it:
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Extra ltem Properties

General
ﬁ T-5hirt (£15.00)
Value: ]

You can change the extra items in the Tournament Properties on the Entry Fees tab.
You can enter the paid amount here or on the Match Properties on the Payments tab.
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Note tab

17 Michael Dekker Properties
General | Address I Sport I Events | Availability
Fee | Mote | Messages

! o[ et ][

On the Note tab you can enter some notes about this player.
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Messages tab

17 Michael Dekker Properties
General Address Sport Events Availability
Fee Mote Messages
Type Created Subject
s E-mail 7172014 3:04:51PM  Demo Tournament
£ >

On the Messages tab you can see all the messages addressed to this player.



Matches of player

At any time you can press F10 to show the matches of a player. If you press F10 you can select a player.

Select Player

Flayer

&2 abdul, Mohd Zak
Q Adriyanti, Fird

a Ahsa, Muhammad
&3 ai, Goto

a Anand, Chet

Q Bae, Youn Joo
Q Baed, Seung

a Baekl, Shinda

a Dekker, Michael
a Dirksen, Johan
a Jansen, Henk

a Mee, Lu

a Smith, Jonathan
a Veldhof, Sebastiaan
.

Member ID 6

Select the player and click OK or press Enter. Now you will get an overview of the planned matches of the

player.
Matches of Chet Anand
=) N X
Draw Round Teaml Team2 Time Court Locat

00 MS - Group B RR2 Mohd Zak Abdul Chet Anand |

i) MS-Group B RR1 Chet Anand  Kevin de Wit

() M5 -GroupB RR3 Chet Anand  Michael Dekker

i) wo Final Fird Adriyanti+Chet Anand  Youn Joo Bae +5eung Baed

You can print the matches, lookup the match in the draw sheet or enter results.
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Import Ranking

You can import ranking data from a Dbase file (*.dbf) or an Excel file (*.xls) so the players ranking information

is updated. Select Player -> Import Ranking from the main menu, click the L B'@%S& | ptton to select a
Dbase or Excel file.

E

Import Ranking

Fields .
Flease select the fields to link to T '

Member ID: | Member ID b
Ranking: W
Points: b4
Ranking Type: W

Players not found in ranking

(®) Reset ranking

() Keep current ranking

= Back Cancel Help

Click Next to link the fields. Now you can link the fields of your import file to the fields of the Tournament
Planner.
The Ranking Type indicates the type of ranking you want to import. Finally you can select what happens to
the ranking data of a player who is not found in the import file.
e Reset ranking
Clear the existing ranking.
e Keep current ranking
The existing ranking will be kept.

Selecting Players
With several actions in the Tournament Planner you have the options to select players, for example when
sending e-mails. This screen allows to to make selections based on different criteria.

On the left side you see a list of all the players in your tournament. You can select manually by checking the
players yourself. Click All to select all players. Click None to de-select all players. Click OK when you are
done selecting players.
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Properties tab

Select Players

| 0 players selected

Flayer

L] a Bolker, Steven

L] 9 Botlava, Christana
(] £ De Beu, Birgit

] a Derksen, Rogier
] a Gross, John

] Q Hammington, Lindsey
] a Hansen, Erik

] Q Hebb, Daisy

] Q Hillary, Fose

L] a Hoekmans, Marc
|:| 9 Hung Yo, Ying

L] Q Jones, Caroline
O a Kamps, Ruud

(] &2 Mcdall, Kate

(] & rood, Patrick

] a Sauer, Richard

] a Schouten, Henk
I_l ﬂ Siehal Tnric

L]

Properties

All Mone

Clubs | Countries | Events

[ Imen

|:| Women

Level

Days

Age From:

Age To:

[ ]Players with e-mail
[ |Players without e-mail

[ ]Players with mobile
[ ]Players without mobile

[ IManual entries
|:| Internet entries

[ ]Paid
[ IMot paid

Select

Cancel

On this tab you can select the properties a player must have to be selected. You can select all men, all women,
or players of a certain age range. Click Select to add all players to the selection who match one of the
selected properties. You can make a selection on players with or without e-mail, manual or Internet Entries and
players who have paid or not paid.
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Clubs tab

Select Players
0 players selected
Player * | Properties Clubs | Countries | Events | Level Days
L] a Bolker, Steven Club Al
L] 9 Botlava, Christana n ﬁhclub 1
|:| 9 De Beu, Birgit ? Maone
(] gaciub 2
] a Derksen, Rogier .
(] Gaciub 3
] 3 Gross, John ;
8 (] éuciub 4
] g Hammington, Lindsey .
(] Gaciub 5
] a Hansen, Erik .
8 (] guciub 6
] 9 Hebb, Daisy .
2 (] gaciub 7
] 9 Hillary, Fose ] @Club 3
L] a Hoekmans, Marc
|:| 9 Hung Yo, Ying
L] g Jones, Caroline
O 3 Kamps, Ruud
[ &3 Mcdal, Kate
(] & rood, Patrick
] a Sauer, Richard
] a Schouten, Henk
I_l ﬂ Ciehal  Inrie v

All Mone Select Cancel

On the clubs tab you can select clubs. All members of the selected clubs will be added to your selection when
you click Select.
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Countries

Select Players

0 players selected

Flayer

] a Bolker, Steven

] 9 Botlava, Christana
(] £ De Beu, Birgit

] a Derksen, Rogier
] a Gross, John

] Q Hammington, Lindsey
] a Hansen, Erik

L] Q Hebb, Daisy

] Q Hillary, Fose

] a Hoekmans, Marc
|:| 9 Hung Yo, Ying

] Q Jones, Caroline
] a Kamps, Ruud

(] &2 Mcdall, Kate

(] & rood, Patrick

] a Sauer, Richard

] a Schouten, Henk
I_l ﬂ Siehal Tnric

# || Properties | Clubs | Countries | Byents

Level

Days

Country

L] I]Eielgium
|:| =Botswana
] mCanada
] “China

L] EEgypt

] EEEngIand
|:| EEritrea
L] =Honduras
|:| mIran

] ENepal

] =Neﬂ1erlands
] mPnrtugaI
|:| EF‘.ussia
] Su:ntland
] EThaiIand
v || LI usa

All Mone

Select

All

Maone

Cancel

On the clubs tab you can select clubs. All members of the selected clubs will be added to your selection when

you click Select.
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Events tab

Select Players
0 players selected
Flayer # || Properties | Clubs | Countries | Events | level | Days
L] a Bolker, Steven Event
L] 9 Botlava, ["...hr.ismna ] B MS - Main Draw
[ & pege, Blrglt_ [ ] B ws - Main Draw =
0] a Derksen, Rogier [] @ MD - Main Draw
o a Gross, John [] B wD - Main Draw
] Q Hammington, Lindsey
] a Hansen, Erik
] Q Hebb, Daisy
] Q Hillary, Fose
L] a Hoekmans, Marc
D 9 Hung Yo, Ying
L] 9 Jones, Caroline
] 3 Kamps, Ruud
(] &2 Mcdall, Kate
] a Rood, Patrick
] a Sauer, Richard
(] & schouten, Herk [_] Only without partner
18 cichal tnarie i
All Mone Select Ok Cancel

On the events tab you can select all players entered for the selected events. Click Select to add the players of
the selected events.
When Only without partner is selected, only the players without a partner will be selected.
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Level tab

Select Players
0 players selected

Player » | Properties | Clubs | Countries | Events | Level | Days
L a Bolker, Steven Single Double
E ggzﬁ;:j’;g;tsmna [ <Mone: [] <Monex

r 1 1
L] a Derksen, Rogier E 2 5 5
] 3 Gross, John 3 3
] Q Hammington, Lindsey 4 ] 4
] a Hansen, Erik s s
] Q Hebb, Daisy s s
] Q Hillary, Fose 7 7
] a Hoekmans, Marc s e
D Q Hung Yo, Ying I:l g |:| g
L] Q Jones, Caroline
] 3 Kamps, Ruud
(] &2 Mcdall, Kate
] a Rood, Patrick
] a Sauer, Richard
(] & schouten, Herk Al Mone Al MNone
I_l ﬂ Ciehal  Inrie e

All Mone Select Cancel

On the level tab you can select all players of a certain player level. Click Select to add those players to your
selection
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Days Tab

Select Players
0 players selected
Player # | Properties | Clubs | Countries | Events | Level | Days
] a Bolker, Steven Day Al
E gﬁuﬁavar C.hr.lstana ] FIMon 16/03/2015
De Beu, Birgit D 'jTue 17/03/2015 Maone

L] a Derksen, Rogier

O 3 Gross, John

] 23 Hammington, Lindsey
] a Hansen, Erik

] Eg Hebb, Daisy

] Eg Hillary, F.ose

L] a Hoekmans, Marc

D Eg Hung Yo, Ying

L] E} Jones, Caroline

O 3 Karnps, Fuud

(] &2 Mcdall, Kate

] a Rood, Patrick

] a Sauer, Richard [ ]warned

] a Schouten, Henk
I_l n Siehal Tnric i

All Mone Select Cancel

On the days tab you can select all players who have to play a match on the specified date. Click Select to add
the players of the selected days.

(] EX]wed 18/03/2015
(] EThu 19/03/2015
[ EZ3Fri 20/03/2015

[ ] Esat 21/03/2015
(] Esun 22j03/2015

[ Mot warned - not played

Player Database

The Player Database makes it possible to manage player data from multiple tournaments.

Copy to player database

Select Player -> Player Database -> Copy to player database from the main menu. All players of the
current tournament are now copied to player database. You can now pickup players from the player database
for another tournament. This way you don’t have to fill in all data of the players again, but only select the
events and the availability. Players without a member id are not stored in the player database. If a player
already exists in the player database the old data will be replaced.
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Pickup from player database

You can easily pickup players stored in the player database for a new tournament. Select Player -> Player
Database -> Pickup from player database from the main menu or press F3.

Select Players

g
|:| Men

Wi MName Member ID DOB Club L1 Lz

Dob From: 3 Bolker, Steven 143340 131983 Bakdkum 3 3

Dob To: a Derksen, Roaier 280799 7701973 Egmand 3 3

a Gross, John 2148231 1/15/1969  Bergen 3 3

[ ] Players with e-mail a Hansen, Erik 289223 2/22/1972  Limmen 3 3

[ ] Players withouk e-md a Hoekmans, Marc 275725 6/24/1960  Egmond 3 3

£ kamps, Ruud 738623 10/13/1971 Bakkum 3 3

[ Players with mobile a Rood, Patrick 274270 9/10/1974  Eagmond 3 3

[ ] Players without mobile 3 Sauer, Richard 231456 7/27(1941  Vennewater 3 3

3 Schouten, Henk 266340 371962 Feswielen 3 3

a Siebel, Jaoris 592940 a/7/1952 LTVZ 3 3

a Velden, Dik van de 1562434 afaf197a Bakdum 3 3

a Voort, Diederik van der 695554 8/27/1971  Hogedijk 4 4

a Vries, Michel de 280611 1/22/1974  Egmond 3 3

13 Players

Select the players that you want to add to the current tournament. In the fields on top of the screen you can fill
in the name or the member id of the player you are looking for. Double click the player or click on Add.

If all players you want to add are listed on the left you can click Next.
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Select Players
&8

Please select the events for these entries

Event

B e

| DE

| DE Qualification
§ HD

1 HD Qualification
| oD

| DD Qualification

oooodog

13 Players

You can select an event for the players if you like. Click Finish to add the selected players to your
tournament. Check if personal data like the address or level hasn’t changed.

If you click on Delete Player the player will be removed from the player database. By clicking Clear Player
Database, all the players are removed from the player database.

Import to player database

You can also import data from your member administration. Export all the data of your member administration
program to an Excel (*.xls) file. After that, these files can be imported in to the player database. Select Player
-> Player Database -> Import to player database from the main menu.
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Import To Player Database

File
Select the file to import from ‘

£

Erowse

This wizard allows you to import several file types:

Excel files
Make sure the data is on the first sheet and the first row contains the field names.

< Back Mext = Cancel Help

Click on the button to select the Excel file you want to import. Click Next to link the fields.
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Import To Player Database

Fields
Please select the fields to link to

Member ID: W Phone Home: W
Mame: W Phone Wark: W
First name: W Mabile: W
Middle name: W E-mail: W
Address: W Gender: W
Address 2: W Date of birth: W
Address 3: W Club: W
Postal code: W
City: w
State: W
Country: W

< Back Cancel Help

Now you can link the fields of your import file to the fields of the Tournament Planner. The Tournament Planner
will try to create a link automatically using the fieldnames. You can link the missing fields by hand. If not all
data is present in your Excel file, then they won't either appear in the member file of the Tournament Planner.
Click on Next to continue.
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Import To Player Database

Result '
Verify the result before finally importing it into the
playerdatabase I '
Mame First Name Middl... Address Postal ... Cit
& Hansen Erik 1606A]
8 saver Richard 1825KB
8 vamps Ruud 1316GG
 Hoekmans Marc 160200
2 sicbel Joris 150335
£ velden Dik van de 190 1ML
8 schouten Henk 13236R
8 Rood Patrick 193287
a Voort Diederik wan der 1334EH
£ Bolker Steven 190 1VE
£ >
< Back Mext = Cancel Help

The result is shown. Now you can check if the right data is filled in the right fields. You can go back to make
changes if necessary. Click on Next to import the players in to the player database.

[{ Attention: Players without a member id will not be stored in the player database. If a player already exists

in the player database the

Export player database

You can also export the player database to an Excel file (.xlIs). You can import this file in your member
administration or it can be used for a mail merge by MS-Word. Select Player -> Player Database ->

old data is replaced.

Export player database from the main menu.
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Send e-mails to players in Player Database

You can send players an e-mail from the Player Database.
Go to Player -> Player Database -> Email Player Datase.

Email Player Database

[ ]Men Mame Member ID DoB Ermnail
[ ]women

-

Dob From;

Dob To:

-

& cin i s i e e

35 players selected

< Back Mext = Cancel

You can filter on Men, Woman, Dob From and Dob To.
Click Next > to enter your e-mail message.
Players who don't have an e-mail address won't be in the list.

Import Entries

You can also use a Dbase file (*.dbf) to import players directly into your tournament without using the player
database. Select Player -> Import Entries from the main menu. The Import Entries function works similar to
importing into the player database.



Import Entries

Events
Please select the events for these entries

Event

L] @ ms
L] 8 wms Qualification
O] B ws
] B ws qualification
L] &wm
13 m Qualification
L]Bwp
L[] Bwp Qualification

[ ]Link partners in odd and even rows

< Back Finish Cancel Help

After selecting the players you can also select in which events the selected player will be entered.
Therefore you want to have separate Dbase files for each of your tournaments events. If a player already
exists in your tournament, only the selected event will be added.

Roster

By clicking the Roster button in the Outlook bar you will enter in the Roster view. On the left you can select
an event. On the right you will get an overview of the players participating in the event. You can also create
draw sheets per event. You can find an explanation of the event colors at tournament properties, Events tab.
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Entries tab

ournament

I—|~nl|":\.‘l

Player Draw Report

Internet

HEHE RS e 8808

8 Ms

3

Enfries

Draws

Tennis Tournament Planner - Demo Tournament

Messages  Extra Help

ot g 3

Overview B ws
3 D L=

E wD

WD ) O on s L pd
(O - o - - o - - O A -

£

E

-~

Mame Seed Status  Order

Christana Botava
Birgit De Beu
Lindsey Hammington
Daisy Hebb

Rose Hillary

Yimg Hung Yo
Caroline Jones

kKate Mcdall

Kim de Vries
Shi-Tang Wang

P

Messages

Visual Reality

Main Draw

Qualifying

Lucky Losers / Reserve List /Excude List

On the Entries tab you find a list with all the players participating in the event. All the relevant information to

do the seeding and make the draws is listed.

Click any column name to sort the list. If you double click an entry, or if you select the Properties by right
clicking the entry, you can change some of these properties.

Double Event

In a double event both players have to fill in there partner.

The entries can be subdivided in different groups:

Main Draw tab

By default all entries will be listed in the Main Draw.

Reserve List tab

The reserve players can be moved to the Reserve List.

Exclude List tab

mVM Reality

0 draws, 10 entries (10 Main Draw, 0 Qualifying, 0 Lucky Losers List, 0 Reserve List, 0 Excluded)



The players you exclude by hand can be moved to the Exclude List.
When the Separate seeding option is selected in the properties of an event you will get two extra tabs.

4

b ain Draw / Qualifying [/, Lucky Lozers /4 Reserve Ligt |/ Exclude List

Qualifying tab
Players who are not automatically seeded for the main draw can still qualify by participating in the qualification
draw.

Lucky Losers tab
When a player in the main draw does not show or is injured a lucky loser from the qualify draw will advance
through to the main draw.

You can easily recognize the type of entry by the colors used:

e Green Standard
e Yellow Direct Acceptance
o Grey Reserve
e Red Excluded

Entry properties

If you double click an entry, or if you select the Properties by right clicking the entry, you can change some
of these properties.

Entry Properties
General Withdrawal
-
ﬂ Michael Dekker
Partner: =Mone >

Ewvent: M3

Entry Date: Tue 3/18/2014

Main Draw

Seed: /

Status: | <Mone= W

Acceptance

Order: |<Mone=  w | Position: |0

You can give the entry a Seed, for example 1, 3/4 or 5/8. You can also adjust the Status (Wildcard, Lucky
Loser or Qualifier). You can have separate seedings for the main draw and the qualification. When making the
draw the right one is automatically used. In the tab Events of the Tournament Properties you can select for
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each event separately if you want to use the Separate Seeding.

With a doubles match you can assign a partner. If you select player A as the partner for player B, then player
B will automatically be selected as the partner for player A. You can also select Partner Wanted as a partner.
This reminds you the player is still searching for a partner. A player with a Partner Wanted or No Partner
can not be entered in a draw.

Under Acceptance you can fill in the acceptance position for Main, Qualifying and reserve.
On the Withdrawal tab you can fill in the reason and the time of withdrawn:

Entry Properties

General | Withdrawal

£
Date: | 7/ 8/2014 v | [10:19:31AM =

Reason:

i || & QK Cancel Apply
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Automatic Seeding

[
Click on the Automatic Seeding button in the toolbar o

Order:

Main Draw

0O s N s Ld

11
12

Seed:

Rating

Marme

& Henk Jansen

B Jonathan Smith
B Michael Dekker
B Jan Jansen

B Kevin de Wit

B LuMee

B Muhammad Ahsa
B Mohd Zak Abdul

B Sebastiaan Veldhof

§ Dave de Vries
B Chet Anand
B Shinda Baekl

0 1 2

[ ] Do not seed players without rating

Seed

15

Automatic Seeding

Rating

32 | |64 | |128

Ranking

Points

You can sort the entries on rating or ranking. Use one of the buttons 2, 4, 8, 16, 32 to seed that number of
entries. Click on 0 to remove all seeds.
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Draws tab

v

Tournament

Player

Tennis Tournament Planner - Demo Tournament

Draw  Order of play Report  Internet Messages Extra Help

IEHHTS=(2252 Ralle" 33

3

Owverview

@

Players

|mal
|=rs

Order of play

Matches

Messages

ALTY Daisy

On the Draws tab you can view the draw sheets per event. The following properties are shown:

¢ Name

Type

Size

Group
Consolation

Event

Bt
-1 DE
JHD
oD

Entries | Draws
Mame Type Size Stage Playoff Consolation
|_§]:E] Group A Round Robin 4 1
|_§];] Group B Round Robin 4 1
[ ms Round Robin 5 2

Playoff (yes/no)
Qualification (yes/no)

3 draws, 12 entries (12 Main Draw, 0 Reserve List, 0 Excluded)

If you click Add Draw, the Draw Wizard is started. Click Delete Draw to delete a draw.
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Calculation

During the entry period of your tournament it is possible to calculate the total number of matches based on the
number of entries. Select Draw -> Calculation... to show the calculation screen.

Calculation - Calculation

You will see a list of all the events and the number of matches in the qualification and the main draw. These
calculations are based on a number of settings which you can adjust yourself. Click on Settings to show the

calculation settings.
Calculation

Matches
With your settings, the following number of matches have been caloulated. Your

tournament capadcity is 560,

Event Incomplete  Teams Qualification Main Draw Consolation Total
(1 Total 0 31 4 29 0 33
[] 8 ms 0 12 0 11 0 11
Ews 0 10 0 3 0 3
= 0 4 0 3 0 6
Ewo 0 5 4 0 7
All Mone
Settings Calculation Create Close

When your entry is closed and you are happy with the settings you can make the draws for all your events at
once. Check all the events which you want to create the draws for and click Create. Within seconds your
draws are created and you are ready to do the seeding and make the draws.

If you want to have different draws for specific events uncheck these events before you create the draws.
You can still add draw to this event by using the Draw Wizard from the main menu.
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Calculation - Settings

E

Calculation
-
Settings
Please select the appropriate settings for your events, Double-dick an item to
change the settings.
Entries Type Size  Consolation Playoff  Qualification M. Size
2-4 Round Robin 4 =Mone ] ]
5 Eliminatian 4 Round Robin 2 3
78 Elimination a8 <Mone = i i
2-16 Elimination 16 <Mone = ] ]
17-32 Elimination 32 <Mone > 0 0
3364 Elimination a4 <Mone > 0 0
65-128 Elimination 123 <Mone > 0 0
129-256 Elimination 256 <Mone = 0 0
Properties
Settings Calculation Create Close
For various numbers of entries you can set the type of draw. Double click a setting to change the draws.
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Calculation - Properties

Calculation Properties

 General ;
E 2-4
Qualification
Type: | <Mone:= W
Size: 0
Count: 0 =
Main Draw
Type: |Found Robin v
Size: |4 W
Playoff:  <Mone=
<Mane >
Cons. Playoff:  <Mone=
Cancel Apply

On this screen you can select the type of main draw and the type of qualification draw. Click OK to confirm the
changes. Now click on Calculation to show the adjusted number of matches.



Draw Wizard

Draw Wizard - Draw Arrangement

[ Craw Wizard g

Draw Arrangement
Flease select the appropriate type for this event k. |
MS - 3 - 14 Entries h

Round Robin qualifications with elimination main draw v]

In the qualification-round several round robin's are played. The winners wil proceed to the
elimination main draw. Other players might directly enter the main draw.

= 3

< Back Mext = |’ Cancel ]’ Help

[ ] n. | |
|..r|fr|..r‘..r

First you can select the arrangement of the draws. You can select:
o Elimination

An elimination draw is a knock-out system. You can have a consolation draw and a playoff with it.

¢ Round Robin
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In a round robin every player plays once against every other player.

¢ Round Robin qualifications with elimination main draw

b

A "-.
I

B I"l:. , >
1

C 'l.

D .l.

In the qualification round several round robins are played. The winners will proceed to the elimination
main draw. Other players might directly enter the main draw. The round robins and the elimination main
draw are linked automatically.

« Elimination qualifications with elimination main draw

h
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k

gy

I,

I,

In the qualification round several small eliminations are played. The winners will proceed to the
elimination main draw. Other players might directly enter the main draw. You can have a consolation
draw and a playoff with it.

¢ Round Robin qualification with round robin main draw
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In the qualification round several round robins are played. The winners will proceed to the round robin
main draw. Other players might directly enter the main draw. The qualification round robins and the
round robin main draw are linked automatically.

¢ Round Robin - Full

In a full round robin every player plays twice against every other player. Home and away.

¢ Slugout

A progressive draw is an elimination draw with built-in consolation. Losers of the first round move to the
bottom half.

¢ Compass Draw
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In a compass draw every player plays at least 3 matches.

¢ Qualifying Draw

3+
3+

A qualifying draw is an elimination draw which ends after a number of rounds. The players reaching the
final round will be the qualifiers for the draw in the next stage. This draw is similar to creating several
small elimination draws..

¢ Round Robin with playoffs

gl

Py

2 Round Robins with a size of 4 are played after that the playoffs are played for the places 1-8

e Matchplay
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Matchplay

e Continous Feed-in

After you have selected the arrangement of the draws you can click Next to go to Qualification, Main draw or
the Layout page.



Draw Wizard - Qualification

You can now provide the settings for the qualification round. You can enter the number and the size of the
qualification draws. You can enter the naming of the draws in the Naming field.

Drraw Wizard

Qualification
Provide settings for the qualification round
MS - 3 - 14 Entries

Number Of Qualification Draws

-

3

-

Size Of Qualification Draws

A maximum of 9 entries can be used in the gualification.

Naming

Qualification
@) Letters
() Numbers

Sample: Qualification A, Qualification B, Qualification C, Qualification D

S

NS

< Back ][ Mext = ]’ Cancel ]’

Help

By clicking Next you will enter the Main Draw Page.
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Draw Wizard - Links

When your draw arrangement is Round Robin qualifications with elimination main draw, then you will
also be given a choice whether only the winner or also the runner up will be forwarded to the main draw.

Drraw Wizard @

Links
Please select the number of links to the main draw
MS - 3 - 14 Entries

@ Winner Only
Only the winner of each group forwards to the main draw.

I Nr's 1and 2
Both the winner and the runner up move forward to the main draw. They will be
placed in opposite halves of the draw.

The following links can be added but will not be forwarded automatically.

|:| Bestrr 2

|:| Bestnr 3

If you want to create additional links you can do this using [draw - links] from the main menu.

<Back || mNext> | | cancel || e

In some cases you may have an odd number of round robins, qualifying for an elimination draw. In this case
you may choose to have the Best nr. 2 and Best nr. 3 continue as well in order to fill up the elimination draw.
They will be linked to the elimination draw but will not advance automatically.

If necessary you can go in the main menu Draw -> Links to add extra links.

Click Next to continue to the next screen.
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Draw Wizard - Main Draw

You can now provide the settings for the main Draw. You can enter the size of the main draw keeping the
number of qualification draws in mind. If you have three qualification draws you need at least an elimination
draw of size four or an Round Robin of size three.

Drraw Wizard

Main Draw
Provide settings for the main round
MS - 3 - 14 Entries

Size Of Main Draw

Name

M5 -3

Playoff (3/4)
O

<Back || mext> | | cancel || Heb

e

You can enter a name for the draw. Default the name is set to the name of the event. You can select playoff
if you want to play for a third and fourth place.

If you have selected a single draw in the Draw Arrangement page you can check Qualification if this is a
qualification draw and enter a group number otherwise the Tournament Planner will set this automatically.

Groups and qualification rounds explained

If you are playing qualification rounds with a main draw you must use the group number and qualification
indicator. For all qualification draws check the qualification indicator and enter the same group number.

If you do this then for every elimination draw the winner is and for every round robin every entry is available
as a link in the main draw. For example, if you create four round robins of size three check qualification on all
the draws and give them the same group number. Then create an elimination draw of size four with another
group number. Now you plan this draw in advance, without knowing the winners of the qualification draws.

If you have more than one qualification rounds use the same group number per round. This makes it possible
to play four round robins of size five, then two round robins of size four and have an elimination main draw of
size two. For more information about creating links between draws study the part about Links.

Click Next to continue. If there is a consolation possible you will go to the Consolation page else you will go to
the layout page.
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Draw Wizard - Consolation

If you have select an elimination draw a consolation is possible. Select the type of consolation.

e

Craw Wizard Iél

Consolation
Select the type of consolation you wish to play with your main draw A
MS - 3 - 14 Entries L

@ None
Do not play a consolation.

") First Round
Players losing in the first round of the main draw will go to the consolation. Players
with @ bye may play just one match,

(" First Match
Flayers losing their first match of the main draw will go to the consolation. This will
also forward players with a bye in the first round.

") Full Feed In
Players losing their match in the main draw upto the guarter finals will enter the
consolation draw.

(") Triple Plate
Each player is guaranteed 3 matches.

(") Custom
An extra elimination draw, half the size of the main draw is added. You can decide
yourself which players will enter the consolation and where to put them.

F

Consolation Playo

<Back || Next> | | cancel || e

Select one of the following types of consolation:

None

Do not play a consolation.

First Round

Players losing in the first round of the main draw will go to the consolation. Players with a bye may play
just one match.

First Match

Players losing their first match of the main draw will go to the consolation. This will also forward players
with a bye in the first round.

Full Feed In

Players losing their match in the main draw up to the quarter finals will go to the consolation.

Triple Plate

This consolation adds 3 extra eliminations to your draw and will guarantee each players at least 3
matches before they are out of the tournament. Losers of their first match in the main draw move to the
plate. Losers of the second match in the main draw move to the special plate. Finally losers of the first
match in the plate move to the consolation plate.

Custom

An extra elimination draw half the size of the main draw is added. You can decide yourself which players
will enter the consolation and where to put the

[ Please note: The links in this draw are not made until players are actually in the draw as this type
requires a different set of links for each number of players.

Next will take you to the Layout Page.
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Draw Wizard - Layout

Select the header and the extra columns to be displayed on the draws.

Craw Wizard

Layout

M5 - 3 - 14 Entries

Select the header and the extra columns to be displayed on each draw

Header: [Smndard

Columns:
Colurmn

Membe:
Level

[ status
|:| Rating

[ District

[ Club

[ state

[ Flag

[ pate of Birth

[ ranking

|:| Country

r ID

=

N

| <Back | nmext> | [ cancel ||

Help

Click Next to go to the Finish page.
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Draw Wizard - Finish

On the finish page you will get an overview of the draws and their settings. Verify the settings before you

proceed.
Draw Wizard ﬁ
Finish
Please verify all your settings before proceeding . |
MS - 3 - 14 Entries E._
Mame Type Size Stage Fla... Consolation Cons...
Qualification A Round Robin -~ 3 1 Mo Mo
Qualification B Round Robin -~ 3 1 Mo Mo
Qualification C Round Robin -~ 3 1 Mo Mo
MS -3 Elimination 4 2 Mo Mo
i mm | b
<Back || Fnsh | | canced || hHep

Click on Finish to create the draws and make the links.
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Draw properties

Double click a draw or right click a draw and select Properties to change the properties.

Draw Properties

General | Layout

H == |

Ewvent: HE
Type: | Round Robin W
Size: |4 W
Stage: |1 =
<Mane >
<Mone >
<Mone >

Qualification:

Position: |1 =

You can change the name, the Type (Elimination, Round Robin) and the Size of the draw. You can also select
a Consolation and indicate if you want a playoff. Tick Qualification to make it a qualification draw. With
qualification draws it is important that the stage number is lower than the main draw.

If you want to create draws manually with a qualification then you need to create different draws with different
positions.

The elimination will be Position 1 and the knock-out round will be Position 2. After creating you can double
click on a "Bye" inside the knock-out round and select Links.

[# Attention: If you change the type or the size of a draw all the matches and links are deleted!

On the Layout tab you can select the header and the extra columns to be displayed on the draws.
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Draw Properties

General | Layout

3

Footer: | <Mone =

Colurmns: | Calumn

[ ] Mmember ID
[] Level

] Date of Birth
[] status

|:| Rating

[ ] ranking

[ ] pistrict
[] club

[ city

[] state

|:| Country

] Flag

Lok | el |

Apply

% 7 Vinal Rea(mi«;
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Draws

By clicking the Draws button in the Outlook bar you will enter in the Draws view. It this view you can view
draw sheet, make draws and plan matches.

I—|~E‘L

curnament  Player

JEHHE I

]

e

Tennis Tournament Planner - Demo Tournament

%)

Overview

@3

Players

3 Ms
E ws
3 ™MD
E wp

Messages

Draw Report Internet  Messages Extra  Help
=880 DO R e
Group & | GroupB | Group C | Group D | MS
Flag 1 2 3
’ S (B #3: .3 Mon
1 = Dik van de Velden -.-2[.13_'.»_5‘]2-6 16/03/2015
14:00 Inside
- . y #1i R.1 Mon
2 B 1oris Siebel -rz[.EﬁGD]G 2 16/03/2015
03:00 2 Inside
’ #3: B3 Mon #1: R1 Mon
3 B Rogier Derksen 16/03/2015 | 15/03/2015
14:00 Inside | 09:00 2 Inside
Standings Pl Pts Sets Games
1 Dik van de Velden 2 2-1 9-8
2 Joris Siebel 1 ] 1-2 8-19
3 Rogier Derksen i} ] 0-0 o-0

On the left you can see all events. By clicking on an event the draws will appear on the right, each with their
own tab. Every tab has the name of the draw sheet. Click on a draw to activate it. Now you can move the
cursor with the cursor keys. You can find an explanation of the event colors at tournament properties, Events

tab.

[{ Tip: Press F9 to search for a player in the draw sheets.

Automatic Draw

If you want draw automatically click on Make Draws. The Draw Wizard is started.

mVM Reality
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Automatic Draw Wizard - Event

If you want draw automatically click on Draw -> Make Draws. The Draw Wizard is started. You will now get

a list with all the events on the left. If you click an event and select a group you can view the corresponding
draw sheets.

Draw Wizard

Event
Select the event and the stage of draws you wish to make

Event Stage 1 s
: ::55 Draw Size
4 mD Group A 3
Euwp Group B 3
Group C 3
Group D 3

< Back Mext = Cancel Help

Select the event and group you want to draw and click Next.
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Automatic Draw Wizard - Entries

You will now get a list with all the entries of the event. You can Sort the list no Name, Ranking and rating.

Draw Wizard

Entries of HE
Select the entries to use, Double-dick an entry to adjust the
seeding.

You have currently selected 8 of 12 enfries. Your draws provide space for 8 entries. Click a
column name to sort the entries.

Entries
MName Seed Ratng Ranking Date
[w 1 B Mohd Zak Abdul 3/28/2014
[ 2 B Muhammad Ahsa 3/28/2014
r 3 B Chet Anand 3/28/2014
[ 4 § Shinda Baekl 3/28/2014
[ 5 B Michael Dekker 3/18/2014
[ & [ HenkJansen 422014
N 7 % Jan Jansen 3/18/2014
v & B LuMee 3/7/2013
[v 9 B Jonathan Smith 3/7(2013
[ 10 T Sebastiaan veldhof 3/7(2013
[w 11 T Dave de Vries 3/18/2014
v 12 B Kevin de Wit 3/18/2014
all Mone
= Back Mext = Cancel Help

If you uncheck an entry it will not participate in the draw. If there are too many entries for the drawsheet, all
will participate in the draw but some will not be drawn in. Click on Next to continue.

2 Visal Realily 103



Automatic Draw Wizard - Separation

On the separation page you can select the type of separation for the draw.

Draw Wizard

Separation
Select the type of separation for your draw

Separation:
) None

() Club

() District

() City

() Postalcode
(") state

'ZEZ' Country

" Level

() Availability

Optimization:
(®) Optimal separation
() Separate first round only

<Mone > W

[ |separate doubles partners

= Back Mext = Cancel Help

You can select:
e None (Random)
e Club

e District

o City

e State

e Country

o Level

e Availability

On the bottom you can set the desired level of separation:
¢ Optimal separation
4 players of the same club will be in 4 different quarters.
e Separate first round only
Players from the same group will not play each other in the first round.

Check Separate top 2 from each group to make sure the 2 highest ranked players from each group are in
different halves of the draw.
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Separate doubles partners:
Double partners will not play each other in the first round of a single event.

Click on Next to go to the Result page.

Automatic Draw Wizard - Result

On the Result page you can view the result of the draw and re-make the draw if needed.

Draw Wizard
Result
Please verify the result. Press finish to accept and save the 'ﬂ
changes. | '
Re-make Draw
Lime Seed Team Separation
it Group A
1 Mohd Zak Abdul Afghanistan
2 Jonathan Smith Metherlands
3 Kevin de Wit Metherlands
4 Chet Anand Serbia
E-] Group B
1 Henk Jansen Belgium
2 Lu Mee France
3 Michael Dekker Metherlands
4 Dave de Vries Metherlands
< Back Finish Cancel Help

Click on Re-make Draw to draw again. Click on Next to accept the draw and save the changes.
Attention: If you make the draws automatically:

¢ The automatic draw will remove the previous and manual draws.
e If you re-make a draw the draw will not be the same.
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Manual Draw

You can also make a manual draw. Select with the mouse or with the cursor keys an empty position in the first
round, and click the button Select Entry or press Enter. You will get a list with entries that aren’t in the draw
yet. Select an entry from the list and press OK to place the entry in the draw.

Select Entry

Main Draw Entries | Qualifying Draw Entries | Links |
Mame Seed Ratng  Rarking "™
Sauer, Richard
ff Gross, John 4
Vries, Michel de
ff Hoskmans, Marc 2
Velden, Dik van de
ff Rood, Patrick 1
Schouten, Henk
f§ Sauer, Richard 3
Bolker, Steven
ff Schouten, Henk 1
Rood, Patrick
B velden, Dik van de 2
Hoekmans, Marc
B \rice Michsl ds 4 W
oK | | Cancel

Click delete to remove the selected entry from the draw.

Automatic Scheduling

If you click on Draw -> Schedule Tournament the Automatic Scheduling Wizard is started.
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Automatic Scheduling - Draws

If you click on Schedule Tournament the Automatic Scheduling Wizard is started. You will get an
overview with all the draws in the tournament.

Automatic Scheduling

Draws
Select the draws you wish to schedule

Marme Type Size Stage Consola... F
[] ms- Group A Round Robin 3 1
[ ms- Group B Round Robin 3 1
[ ms- Group C Round Robin -~ 3 1
] ms- Group D Round Robin 3 1
L[] ms Round Robin 4 2
L] mp Round Robin 4 1
L4 >
All Mone
< Back Mext = Cancel Help

Select the draws you want to schedule automatically. Click on All to select all draws, click None to de-select
all draws. Click Next to go to the Settings page where you can set up the scheduling.
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Automatic Scheduling - Settings

On the Settings page you can set up the scheduling.

Automatic Scheduling

Settings
Please verify all settings before proceeding

Matches
Forward players with byes to the next round

Only first matches, also for players with a bye (¥
Rest Time

150 | =
Start From

] sat 1/3/2015 w 09:00 w

Maximum matches

Per day: |3 =
Per event per day: |2 =

Singles per day: |2 =

< Back Cancel Help

If you want to Forward players with byes to the next round you can check it. You can also indicate which
matches should be scheduled:

e Only first matches, also for players with a bye

e Only matches where both players are known

o All matches

The time between matches can be set up separately for elimination draws and round robins at Rest Periods.
At Start From the day and time can be selected where to start automatic planning from. You can also enter
the Maximum matches per player per day, per event per day and singles per day.

[{ Tip: At an open tournament it is advised to set up Rest Periods for round robins higher. This way a round
robin won't be finished already in the first weekend. You can also use the maximum matches per event to
accomplish this.

Click on Next to start the automatic planning.
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Scheduling per round

This scheduling method allows you to schedule your draws per round. Select your draw and right-click on a
match in a round. Select Schedule Round from the menu.

Planning M5 - Group A -

B 1o courts Mo available courts | Current scheduled time
Available Courts:

Location-filter: | ¥ Inside (4 courts) v Court-filter: <All Courts>
Capadty: 280 g 2 g - oM W = d 9@
Used: 11 T 8E-ws80&8d 8

- :n-ggﬂ'n'u'u'u'u'n
32?3333333

Mon 3/16/2015 29 0 4 1 4 0 4 4 4 4 4
Tue3/17/2015 40 4 4 4 4 4 4 4 4 4 4
Wed 3/18/2015 40 4 4 4 4 4 4 4 4 4 4
Thu3/13/2015 40 4 4 4 4 4 4 4 4 4 4
Fri3/20/2015 40 4 4 4 4 4 4 4 4 4 4
Sat3/21/2015 40 4 4 4 4 4 4 4 4 4 4
Sun3f22/2015 40 4 4 4 4 4 4 4 4 4 4

Scheduled: 0 matches.

Team 1 Team 2 Time Court

';} Steven Bolker[1/5]  Patrick Rood (Mon 3/16/2015 11:30 ...

5] Dik van de Velden  Joris Siebel (Mon 3/16/2015 11:30 ...

2 Fuud Kamps  Erik Hansen (Mon 3/16/2015 11:30 ...

()] Marc Hoekmans  Richard Sauer (Mon 3/16/2015 11:30 ...
Skip matches with bye Max matches per day: |3 = Rest time: |150 =
Forward byes Max matches per event per day: |2 = Max matches per time slot: |0 =
[ |Reverse Matches Max singles per day: |2
[ ] auto Assign Courts Start court: <Mone= W cancel

You will see all the matches in this round with the proposed playing times. On the top half you can see your
court usage. Click on any time in the court usage to re-schedule the matches in this round. The used timeslots
for this round are marked in purple. The Tournament Planner will schedule matches after each other using the
settings on the bottom of the screen. Below the timeslots you can see how many matches will be scheduled.

Use the Court-filter or Location-filter to schedule your matches.
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Select Courts

Court

[] 1-Tennigpark Alkmaar
[] 2 -Tennigpark Alkmaar
[] 3 - Tennispark Alkmaar
[ ] 4 - Tennispark Alkmaar
[ ] 1-Tennispark Schagen
[ ] 2 - Tennispark Schagen
[] 3 - Tennispark Schagen
[ ] 4 -Tennispark Schagen
[] 1-Tennigpark Schoorl
[] 2 -Tennigpark Schoorl
[] 3 - Tennispark Schoorl
[ ] 4 - Tennispark Schoorl

The following options are available:

e Skip matches with bye
If a match has 1 or 2 byes it will not be scheduled.

e Forward Byes
When a match has 1 bye, the other player will be forwarded to the next round.

e Assign Courts
Scheduled matches will automatically assigned to a free court.

¢ Max matches per time slot
This settings is the maximum number of matches in this round to be scheduled at the same time. When
you set this to 0 there will be no maximum. This setting is very useful if you want to schedule half of the
courts for the Men’s Single and the other half for the Women’s Single.

¢ Rest Periods
This is the number of time slots skipped before a player can play another match.

¢ Max matches per day
This setting is the maximum number of matches for each player per day. When the maximum is
reached, the match will be scheduled on the next day.

¢ Max matches per event per day
This setting is the maximum number of matches per event for each player. When the maximum is
reached, the match will be scheduled on the next day.

¢ Max singles per day
This setting is the maximum number of single matches for each player. When the maximum is reached,
the match will be scheduled on the next day.

It is possible to schedule matches on a day without specifying a time. You may want to determine the exact
time on a later moment. Click on a date in the court usage to schedule on a day.

[{ Attention: scheduling on a day does not check player or court availability and other matches. This will be
done when specifying a time.

Click OK to confirm the scheduling of the matches on the screen.

[{ Attention: matches that are scheduled before you go to round scheduling will not be affected.
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Manual Scheduling

You can also schedule matches by hand. Select a match from the match list or a draw and press F7. You will
get the planning window.

Planning HE - Group A - |

M 1o courts Player not available Singles before doubles B current schedule:
Mo available courts Rest time Match before or after Available for this |
Location-filter: | ] Tennispark Alkmaar (4 courts) w Court-filter: <Al Courts = W
4 :
3 -
2 4
1 4
09:00 10: 15 ' 11:30
o T PR R S
W O = k&
= R A T,
o m o oo oW

Sat 1/3/2015
Sun 1/4/2015
Sat 1/10/2015
Sun 1/11/2015

Court; i v Max matches per day: |3 = [ ] singles before
Auto Assign Courts Max matches per event per day: |2 = [ |Foree planning
Rest time: |60 = Max singles per day: |2

The cursor is automatically placed on the current planning and otherwise on the first available time. Use the
cursor keys to select another day and time. The matrix uses for indication several color blocks:

[
D O =M
o = W s O
o m o ;oo

Sat 1/3/2015 ()
Sun 1/4/2015

Sat 1/10/2015

Sun 1/11/2015

¢ Grey
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These times are blocked because this is a match prior or following the current planned match.
¢ Red
These times are blocked because one or more players are not available.
¢ Black
These time are blocked because there are no courts available for scheduling.
¢ Green
These times are blocked because all courts are in use.
e Orange
These times are blocked because one or more player are in their rest periods.
e Light blue
This block shows the current planned day and time of the match. It is possible to move this match to
another time.

The white color indicates the available times for this match, the cursor itself has got a gray shaded color. Use
the cursor keys to move the cursor. When you click Force Planning, then you can schedule the match without
taking player or court availability into account.

You can schedule a match on a day without specifying a time by clicking on a date. You can specify a time later
by re-scheduling the match.

Court capacity graphic

4
2]
2
1

09:00 AM 10:15 AM 11:30 AM 12:45PM 02:00 PM 03:15PM

The Court capacity graphic is an extra aid for planning your tournament. It gives you the ability to see in a
glance what the court capacity is and how many courts are used during the day. The blue line indicates the
total court capacity. When there are matches planned this is indicated with a blue block. When the court
capacity is reached a green block is displayed and when there are more matches planned then there are
courts available a red block is displayed.

By clicking on the tournament days you get a overall image how the day is scheduled:

iz e —e
M 1o courts Player not available Singles before doubles M current
Mo available courts Rest time Match before or after Availab
Location-filter: | ¥ Tennispark Alkmaar (4 courts) W Court-filter: <All Courts:= '
4
3 i
2_
1 4
09:00 10:15 ' 11:30
0 e e e e
w O = e
Fe I T S R
Lo T o ) R R oy (R e AR |

sat 1/3/2015 ()
Sun 1/4/2015

Sat 1/10/2015 [}
5un 1/11/2015

)
bt
=

-

Filters
The graphic shows all courts of the tournament. With the location-filter you can display the court capacity of

m Visal Reality 112



one location. For instance: when a tournament is held on two locations and we select the filter location A, then
the court capacity graphic will only display the courts assigned in the tournament properties to this location. All
matches will now automatically be planned on the courts present on location A.

With the court-filter you can display the time planning for a specific court. This option gives you a overall
image when the court is taken and when it's free. This is ideal
for the tournament director to plan a exciting match on the best suitable court, like a center court.

By selecting Auto Assign Court the match will automatically be scheduled on a free court available with the
selected filter.

[ Attention: scheduling on a day does not check player or court availability and other matches. This will be
done when specifying a time.

The following options are available:

¢ Rest Periods
This is the number of time slots skipped before a player can play another match.

¢ Max matches per day
This setting is the maximum number of matches for each player per day. When the maximum is
reached, the match will be scheduled on the next day.

¢ Max matches per event per day
This setting is the maximum number of matches per event for each player. When the maximum is
reached, the match will be scheduled on the next day.

¢ Max singles per day
This setting is the maximum number of single matches for each player. When the maximum is reached,
the match will be scheduled on the next day.

On the right of the planning window you see the details window. This window gives you the opportunity to see if
a player is available for the match. You can see very easily who is and who is not available, because the
players who are not available are indicated in red. In the right column you can see the number of events
players are still in.

If there is a picture shown of a memo it means this player has a memo. Click on the player to make the memo
visible at the bottom. You can show the match memo by clicking on the tab Match Note. You can check
Highlight to indicate this match should be highlighted in the draw and match listings.

In the right column you can see the number of events the player is still active in. This is usefull information
when determining the priority of the match. Click OK to schedule the match. If you press delete you can un-
schedule a match.
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Match Numbers

It is possible to create your own list of Match Numbers. Select from the main menu Draw -> Match
Numbers.

Match Numbers

Day =
Start Value: |1 =
FMon 16/03/2015
ETue 17/03/2015 Matches: 10
Elwed 18/03/2015
Ethu 19/03/2015
EFri 20/03/2015
Efsat 21/03f2015
[sun 22j03/2015

Location: <all= W

You can create for each day separately the list of match numbers. Select the Day and Location on the left
and set the Start Value on the right. Click OK to confirm.
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Validate schedule

Navigate to Draw -> Validate schedule to check if players has exceeded the max matches per day or event,

max singles or rest time.

v

g O3
List Settings

Schedule Validation

—y

Day: |Eﬁ Sun 1/4/2015

v

Mame Draw

Max matches
3 Henrk Jansen
a Sebastizan Veldhof

Max singles

a Henk Jansen
a8

Sebastiaan Veldhof
Max matches per event

3 Henrk Jansen
a

Sebastizan Veldhaof

Round Time

Comment

2 Matches
2 Matches

2 Singles matches
2 Singles matches

2 Matches in M3
2 Matches in M5

By using the Settings option you can edit your wishes.

7
my OIS
Settings

Schedule Validation

Rest Time

Rest Time: %

OOP: %

Singles after doubles

Late Finish - Early Start

Finish After: |19:00

Start Before:

max matches per day

=

max per event per day

=

max singles per day

=
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Urgent Matches

Go to Draw -> Urgent Matches to open the Urgent Matches list.

7] Urgent Matches

_'_.! -zl J

Draw Round Teaml Team2 Matches Mot Av..

'_:} MD RR1 John Gross-+Hvichel de Vries[4] Patrick Rood-+Henk Schouten[1] a8 |
i) MD RR3 Steven Bolker +Richard Sauer[3]  Patrick Rood+Henk Schouten[[1] ] l
i) MD RR2Z Marc Hoekmans +Dik van de Velden[2]  Patrick Rood+Henk Schouten[1] ] (
i) MD RR2 John Gross+Michel de Vries[4]  Steven Bolker +Richard Sauer[3] ] l
i) MD RR3 John Gross-+Hvichel de Vries[4]  Marc Hoekmans+Dik van de Velden[Z] a8 l
i) MD RR1 Steven Bolker +Richard Sauer[3]  Marc Hoekmans+Dik wan de Velden[Z] a l
Player Active Events Matches Mot Availab...

2 1ohn Gross M5 MD 8 0

{2 Michel de Vries M5 MD 8 0

43 Patrick Rood M5 MD 8 0

2 Henk Schouten M5 MD 8 0

The Urgent Matches list is based on the availability and number of matches from a player. Players with more
events or bigger draws will be on top. These matches can be scheduled first.

[¥ Note! The matches with players will show up only!



Links

Select Draw -> Links from the main menu. You will now get an overview of all available and created links.

7] Links - o]
33 & 3

Draw Ready Link Status Team Target

2 MS - Group A No (2] Group A #1 Linked Steven Bolker M5 Line 1

1 M5 - Group B No [#] Groupa 22 Not Linked

1 M5 - Group C Mo [#] Group A £3 Mot Linked

Q M5 - Group D Mo

On the left you can select the draw sheet, on the right all the links are displayed concerning the selected draw
sheet. Every link will show its position from the qualification draw, the status and the forwarded team. The
ready state next to the draw name will indicate if the qualification draw is played.

The status can be:
¢ Forwarded
There is a link and the team is forwarded.
e Linked
The link is created.
¢ Not Linked
There is no link for this position.

If a link is created and the qualification draw is played, then it is possible to advance the player to the main
draw by clicking Forward. If you right click a link and select Show Link Source the qualification draw is
opened. If you select Show Link Target the Target draw where the link is linked to is opened.

You can add you own links as well (manual links) with the button Add Link. These manual links can have any
name you want. The main purpose is to show the source of a player in the next stage of the draws, for
example ‘Best No. 2. Manual links will never be forwarded automatically. After the source draw is finished you
need to replace the link in the target draw with the correct player. You can delete a manual link using the
button Delete Link.

Create Links

If there are qualification draws is this event, you can link these draws with the main draw. In case of an
elimination draw the winner is available and in case of a round robin every position is available as a link for
main draw.

To make a link select with the mouse or with the cursor keys an empty position in the first round of the main
draw, and click the button Select Entry or press Enter. Now select the Links tab. You will get a list with
available winners and/or round robin positions that aren’t in the draw yet.
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Select Entry

Main Draw Entries | Links

Marne

Group A 1
Group A %2
Group A #3
Group A #4
Group B #1
Group B %2
Group B %3
Group B ¥4

Select a link from the list and press OK to place the link in the draw. Click delete to remove the selected link
from the draw.

Draw Standings

The draw standings are automatically calculated according to the rules defined in the tournament properties.
However it can be possible more than one players end get the same ranking in a round robin. You can then
manually adjust the standings yourself. Select Draw -> Adjust Standings from the main menu.
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17 Adjust Standings - O
difjoo|a

Draw Ready Team MR Rnk Pl Pts Sets G...

3+ [ Ms - Group A Mo B Steven Bolker i 1 0 0

3+ J]Ms - Group B Mo & Patrick Rood 2 1 0 o

s L§ﬂ M5 - Group C Mo & John Gross 3 1 0 0

i L§ﬂ MS - Group D Mo

2 EHwms Mo

2 Fmo Mo

To change a round robin to manual calculation click on manual. You will now see a humbered ranking in the
standings. To change the ranking order click on a player and use the buttons up and down to change the
players ranking. When you decide to move back to the calculated ranking click on calculate.
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Clear Draws

If desired you can clear whole draws in one time. To do this, select Draw -> Clear draws from the main

menu. You will now get this window.

Clear Draws
Select the draws you wish to dear
Draw Type Size  Consolation Playoff
Q‘] MS - Group A F.ound Robin 3 Mo
2 MS - Group B Found Raobin 3 Mo
H Ms - Group C Round Robin 3 Mo
ZH MS - Group D Round Robin 3 Mo
H ms Round Robin 4 Mo
2H MD Round Robin 4 Mo
All Mone
Times [ ] offidals

You can select the draws you want to clear. Click on All to select all draws, click None to de-select all draws.
If you just want to clear the scheduling, select Times. If you just want to clear the results and/or players you
can select Results and/or Players. Click OK to clear the selected draws. The draws will not be removed, only

cleared.
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Change partner

If you want to change the partner for an entry after you have already have scheduled the matches then select
the entry and click by using the right mouse button -> Change partner.

Replace Partner
Which player do you want to replace? Matches Of Team
(") Steven Balker Event Time
':E:' Richard Sauer MD Mon 3/16/2015 10:15 AM
Mew Partner: Matches Of
Gross, John W Event Time
Ok Cancel

You can now change one of the partners. The new partner will be replaced in all matches that were already
planned. On the left top you can select which of the two players needs to be replaced.

Then select a new partner. Make sure the new partner is entered for the event. If there is already a match
planned for this new partner on a time the team is also playing, then you will get a message. You cannot plan
the new players until the conflicting match is removed from that point of time. Click OK to replace the partner.
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Draw Location

When a tournament is held on several locations it's possible to link a draw to a location. Select from the main

menu Draw -> Draw Location.

Draw Location

Draw

E‘] M3 - Group A
E‘] M3 - Group B
E‘] M3 - Group C
E‘] M5 - Group D
=t ms
& MD

Location

Inside
Inside
Inside
Inside
Dutside
Dutside

Court

=<

Clear

Location

E Inside
] outside

Court

<All Courts =

] 1

On the left you can select a draw and on the right the location. Press on to link them to each other.
When you schedule the draw all matches will be automatically planned on the linked location. It's always
possible to make changes and schedule matches manually on a different location. If you want that the draw is
played on a specific court you can also link the draw to a specific court.
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Draw Layout

You can change the layout for multiple draws at the same time. Select Draw -> Layout... from the main
menu.

Draw Layout
Select the draws and the layout
Draw Foater: <Mone > W
[l E}j MS - Group A Columns: Column
] E}:] M5 - Group B
] E}j MS - Group C [ ] Member ID
] E}] MS - Group D [] Level
O ms [] Date of Birth
(1 Mo [ status
|:| Rating
[ | Ranking
[ ] pistrict
[ ] cClub
[] city
[ ] state
[ ] Country
[ | Flag

All Mone Cancel

Check the draws you want to change on the left. Click on All to select all draws, click None to de-select all
draws. Select a draw header and check the desired column. Click OK to update the draws with the new layout.
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Matches

By clicking the Matches button in the left menubar you will enter in the Matches view.

Tennis Tournament Planner - Demo Tournal

I—|~E‘L

curnament Player Draw Order of play Report Internet [Messages Extra Help

1IEHH S ez | 82660 E-§-m3

%)

S
I 2 E = Es RS = e
=l [l [ (& (& (S [ (S (S

= 3

Overview aall |mal =l
W Time Draw Round  Nr Team 1 Team 2
IJ Sat 1/3/2015 10:15 HE - Group B RR1 #2 Henk Jansen I] =EE
Players () Sat 1/3/2015 #1 HE - Group A RR1 #1 Jonathan Smith T o Ken
()] Sat 1/3/2015 #1 HE - Group A RR1 F£2 Mohd Zak Abdul [TE2] IF Ch
a 0] Sun 1/4/2015 10:15 HE - Group A RR3 # Mohd Zak ADOLI ) e RE.
I;} Sun 1/4/2015 10:15 HE - Group A RR3 # Jonathan Smith : ChE
Roster ®) Sun 142015 11:30  HE - Group A RR2 = Mohd Zak Abdul (o] [ Jor
(@] Sun 1/4/2015 12:45 HE - Group A RR2 # Kevin de Vit [ A Che
g (0] Sat 1/10/2015 09:00 HE R15 # Herk Janzen T
[©] Sat 1/10/2015 12:45 HE R15 # Lu Mez [ TN B 2
Draws - - _
(@] Sat 1/10/2015 14:00 HE QF #11 Kevin de Wit [ A Che
| (8] Sun 1/11,/2015 10:15 HE QF # Michael Dekker H. Jans:
=i 2 Sun 1/11/2015 11:30 HE QF #10 Dave de Vries [ L. Met ¢

Order of play

Matches

Messages

Scheduled /Mot Scheduled |/, Finished

ALTV Daisy [Enter] Score [FE] Show Draw [F9] Find Player In Draw [F10] Player Matches

An overview is displayed of all the matches. You can change the view to Scheduled, Not Scheduled or
Finished matches by clicking the tabs on the bottom. The matches are ordered by the scheduled times,
displaying the first match to play on top. If a match has a note attached you can view it by placing your
mouse-cursor over the note-icon.

The players can be displayed in different ways depending on their status:

¢ Blue
As a standard all players are displayed in blue. This means that the player hasn’t checked in and isn't
warned yet.

e Green
If a player is displayed in green, it means the player hasn’t checked in but is yet warned.

¢ Black
If a player is displayed in black then he or she is present.

¢ Red underline
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You can tell by the red underline that a player hasn’t paid the fee yet.

e Red text
The player is currently on court.

¢ Memo Icon
A sign of a memo means the match has a memo. You can right click the match and select Match
Properties. On the Note tab you can read the memo.

¢ Watch
When a match has ended a watch will appear behind the names of the players displaying the remaining
rest time. When there is no watch visible the rest time has ended.

Highlighted matches are displayed in bright yellow to attract your attention.

To search for a match of a certain player you can use the search field. Filling in the name will highlight all the
matches of the player in green. With the location filter it is possible to only display the matches for a specific
location.

[{ Tip: Press F9 to search for a player in the draws.

[ Tip: If you want to view the player in the player view right click on a match and select the player.

[ Tip: Press F6 to find the selected match in the draw sheets.

By double clicking on the match, pressing enter or clicking the Match Properties you can enter the result of
the match or change the status of a player. The match properties dialog is opened.

Score tab

At Court you can select the court where the match should be played. If the match is finished you can enter the
result. Use the cursor keys to navigate through the score field. In the Tournament Properties you can select
if the score should be auto completed. If so, it helps you to enter scores quickly. Just enter the score of the
losing team and the tournament planner will automatically complete the rest. If you want to enter the score 15-
7 15-1, just simply enter 7 and 1.
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Match Information

Score | Checkin | Warned | Payments | Mote | Messages
Draw: HE - Group A

'-.' ) Round: RR3

MNry #5

Time: Sun 1/4/2015 10:15

Score:

B Mohd Zak Abdul

B Fivin e Wit
Tie-break

Status: W

Winner: F4 (@) Unknown
F5 () Mohd Zak Abdul
F6 () Kevin de Wit
F7 () Tie

Court: E 1 - Tennispark Alkmaar b

-

Duration: (0

*

Limpire: =Mone = W

The winner is selected automatically during your input of the score. With the Function-keys you can select a
winner yourself. If necessary you can add an indication for walkover, retired, disqualification or a No
Match. At Duration the match duration can be filled in. At Umpire you can select the umpire for this match.
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Check in tab

Match Information

Score | Checkin | Warned | Payments | Note | Messages

&

Mohd Zak Abdul

Kevin de Wit

concel | | somy

You can indicate if the players have checked in. In case of a double event all players can be checked in
separately.
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Warned tab

Match Information

Score | Checkin | Warned |Payments | Note | Messages

[ d Scheduled Sun 1/4/2015 10:15
& (Previously Sun 1/4/2015 11:30)
[ Imohd Zak abdul

E-mail SMS

m
i

Lo

£n

[ Kevin de wit

Ln
i

E-mail

m
i

Lo

£n

You can indicate the players as warned. In case of a double event all players can be marked as warned
separately. If the player’s phone number is known, you can click on the telephone button to dial the number.

Use the E-mail or SMS button to automatically create a message for the player.
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Payments tab

Match Information

Score | Checkin | Warned | Payments | Note | Messages

Gy

Mohd Zak Abdul £50.00 | Receipt

Discount: Balance Due: €50.00 Pay

Receipt

Discount: Balance Due: Pay
Kevin de Wit £€25.00 | Receipt

Discount: 0.00| Balance Due: €25.00 Pay
Receipt

Discount: Balance Due: Pay

You can check the players that have paid the fee. In case of a double event all players can be checked
separately. At paid you can enter the amount paid at discount the discount the player received. If you click
Pay the amount to pay is filled in paid. If you click Receipt a receipt for each player can be printed.

[ Tip: You can also print the receipt beforehand, but only after payment the players will get their receipt.
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Note tab

Match Information

Score | Checkin | Warned | Payments | Mote

[ Ht [ ] Highlight

Messages

On the Note tab you can edit the match note if needed and you can highlight the match to make it stand out on
the draw or in the match list on your screen. This will indicate this match needs your attention.

Assigning courts

You can assign a match to a court. You can do this by clicking Match to court and then select a court. You can
also drag and drop a match on a court using your mouse. If the match is finished and you have filled in the
result, the court will automatically be freed. Also if you assign another match to a court, the assigned court of
the prior match will be freed. You can also click on Free court and select the court in order to free it
manually. Another way of freeing a court is to right click the court and select Free Court.
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; BTl T W sl 3 B WP B
S -3-1(16)
‘C David Bakker - Henk Schouten
Start: 10:49 (1 minutes)

[ Tip: Hover your mouse over a court to see who is playing there.

Notities

By clicking on the Notes button on the navigation bar on the left you can switch to the Notes screen.

7] Tennis Tournament Planner - Demo Tournament - O I
To

urnament Player Draw Report |[nternet [Messages [Extra Help

NEHHETFSe=288808 (812

%
- Modified Due Date Player Subject
Owerview
: | Fri 16/01/2015 15:18  Wed 04/03/2015 Rogier Cierksen Plaver is sick
Flayers
E+)
Roster
Draws
- £
: Player: Rogier Derksen &p & £
Matches Date: Fri 15/01/2015 15:18 Due: Wed 04/03/2015
Flayer is sick

Messages
Visual Reality

You will see an overview of all your notes. Click Add Note to create a new note. You can edit your note in the
yellow box. Click Select Player to assign a player to this memo. You can click Clear Player to remove the
player.

The last modification date of the note is automatically saved when you edit a note. You can use the phone
buttons to contact a player. Click on Show Player to show the details of the assigned player.

You can mark your note as done by placing a check in the box in the list. The font will be changed to
strikethrough. Click on Delete Note to delete the selected note.
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Order of Play

By clicking the Order of play button in the Outlook bar you will enter the Order of play view.
Please note this option is only visible if you have selected this in the tournament properties, draws tab.

Tennis Tournament Planner - Demo Tournal

I—|~nll'::.‘l

curnament Player Draw  Order of play Report  Internet  Messages Extra  Help
NEHRHFSe= 8802

o B

i Draw: |HE -Group A v Round: |RR1 W Auto Fil
Owverview

Team 1 Team 2 Order

m E| Jonathan Smith (MED) Kevin de Wit (MED) 1zt mz

Players E| Mohd Zak Abdul (AFG) Chet Anand (SRE) 1zt mz

E Total matches: 2, Mot scheduled: 0

Draws Show Match List Location: Al -

— {Sat 1/3j2015 1| sun 1/4/2015 | Sat 1/10/2015 | Sun 1/11/2015

|-f:€ .....................................

Order of play 1 2 3

Starting at 10:00 Starting at 10:00
I;D 1 HE RRI HE RR1I

Jonathan Smith (MED) Mohd Zak Abdul (AFG)

V5 V5
[j' Kevin de Wit (NED) Chet Anand (SRE)

Messages

ALTY Daisy 24 cells, 2 matches, 2 not finished

The order of play is an alternative way of scheduling your matches using the follow-by system. On the top-half
of the screen you can select the draw and the round you want to schedule, which will show you all the matches
in that round. Simply drag a match from the list onto the grid to schedule it. You can move matches to other

courts or rounds by dragging them from one cell to the other. To remove a match, select it and press the
delete key.

Cells can be colored when a player has multiple matches on the same day.
Green: One of the players has another match with plenty of space in between.
Yellow: One of the players has another match in a consecutive round.

Red: One of the players has another match in the same round.

You can change the properties of the order of play by selecting Order of play->Properties from the menu.
You can change a specific cell by selecting Order of play->Cell properties from the menu.
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Order of Play Properties

Order of Play Properties

General | Layout

Header: || |

Text 1.
Text 2:

Text 3:

Released: 10/30/2014  w| | 4:30:48PM == | | Mow

Courts per page: 4
Rounds per page: &

Orientation: (®) Portrait () Landscape

At Courts you can select the courts to be used for this day. At rounds you can select the number of rounds to
be played.

The Header is optional and when specified it will print bold on top of the order of play. At Text 1,2 and 3 you
can place some remarks for the players. These will be printed in the footer of the page.

Released allows you to specify the release date of the order of play..
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Order of Play Cell Properties

Cell Properties

General

&<

Heading: Starting at LY

Time: 10:00

Free Text:

At Heading you can set the celltype, for example 'Starting at' or 'followed by'. Where needed you can specify
the time as well.
At free text you can place a remark in the cell.
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Messages

By clicking on the Messages button on the navigation bar on the left you can switch to the Messages screen.

7} Tennis Tournament Planner - Demo Tournal
Tournament  Player Draw  Order of play Beport  Internet  Messages Extra  Help
NEHHTFI =2 (228808

D@ Type Status Player Created Sent Subject
VErViEw
=] E-mail Sent per e-mail Dave de Vries 3/25/2014 8:51:27 AM  8/25/20149:15:22 AM  Demo To
=] E-mail Sent per e-mail Youn Joo Bae 3/25/2014 9:43:13 AM  8/25/2014 9:43:21 AM  Demao To
@ =] E-mail Sent per e-mail Goto Aj 3/25/2014 9:458:10 AM  8/25/2014 9:48:17 AM  Demao To
Players =] E-mail Sent per e-mail Henk Jansen 8/25/20149:52:12 AM  §/25/2014 9:52:35 AM  Demo Tc
#® |E-mail  [Confrmed ~ |Michael Dekker 7/17/2014 3:04:51PM |7/17/2014 3:05:04 PM
E+)
Roster
Draws
[ Toc robbert@toernooi.nl
|.='E‘ Subject: Demo Tournament
Order of play
Matches First matches of Michael Dekker
- Ewvent Time Location
u M35 Sat 1/3/2015 10:15 (Court: 1, Tenni:
Motes
Messages
ALTV Daisy | 5 message(s), 0 not sent

You will see an overview of all your messages. Messages can be created on several places in the Tournament
Planner:

e On the player screen use the button to create an SMS message or to create an E-mail
message.
In the player menu you can select Player -> Send E-mail or Player-> Send SMS.
You can send your first matches using Report -> First Matches -> E-mail or Report -> First
Matches -> SMS.
You can send specific information about a match using the Warned tab on the match properties.
You can send all the player matches in an e-mail message using Report -> Player Matches -> E-
mail.

After a message has been created it will be listed in the Messages screen. You can see when a message has
been created and if it has been sent already. Select a message to view the content on the bottom of the
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screen. Select one or more messages and select Delete in the right-mouse menu to delete the messages. You
can also delete messages using Messages -> Delete from the main menu.

Send Messages
Send Messages

Email
Please select your settings for email messages,

You have & email messages to send.

(" mo confirmation

Set player status to warned

(_) Email confirmation
A read receipt is requested via email

(@) Website confirmation
Your emails will be uploaded to the tournament website, The redpients will get an email
notification so they read the message on the tournament website and the read
confirmation is stored. These confirmations can be downloaded in Tournament Planner.
The Match status will be set to warned when a confirmation is received.

ggg | =] Some providers will not allow you to send large numbers of emails at once. If
you want you can limit the number of emails sent this time.

< Back Cancel Help

Select Messages -> Send All from the main menu. In order to send messages you must have specified your
e-mail settings in the program options. If you did not do so before you will get a warning, and you will be
directed to the options screen where you can enter the correct information.
When sending e-mail messages you have 3 options:
¢ No Confirmation
All e-mails will be sent without a confirmation. You can select to mark the players as warned for their
matches.
e E-mail confirmation
The e-mails will be sent with a read-receipt request. You will get this confirmation in an e-mail sent to
the e-mail address you have specified in the program options. When you receive a confirmation you
must set the warned status for a player yourself in the match properties.
Depending on the settings on the computer of the recipient he may not see the request to send a
confirmation.
e Website confirmation
A link will be added to the e-mail with an text requesting to recipient to click the link in order to send a
confirmation to the tournament director. When the link is clicked the recipient will see a page on the
tournament website. These confirmations can be downloaded directly into the Tournament Planner,
and the match-status for the players will be set to ‘warned’ automatically.

Select the correct setting and click Next.
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Send Messages

SM5
Please select your settings for SMS messages.

You have 0 5MS messages to send,

In order to send SMS messages you must first purchase SMS credits on
our website. Please visit our website for more information:

wanwy, tournamentsoftware, com

Set player status to warned

< Badk Cancel Help

After sending your e-mail messages you will see the screen where you can send you SMS messages. You can
select if you want to set the match-status to warned when the messages are sent. Click Next to continue.
After sending all your messages you will see an overview.

[HAttention: To be able to sent SMS message you need to buy SMS credits in advance. You can order it on our
website.

Pickup Confirmations
If you have sent your messages using an internet confirmation, you can pickup those confirmations by
selecting Messages -> Pickup Confirmations from the main menu.

The confirmations will be picked up directly and the message-status will be set to Confirmed. If the message
contained match information, the match-status of the player will be set to warned.
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The Tournament Planner and the Internet

The Tournament Planner makes it possible to publish your tournament on the Internet very easily. With only
one click on a button your tournament is online. You don’t even need further knowledge of the Internet or
HTML. An Internet connection is all you need.

Players can look up match information and can see their results online. It is even possible to view statistics per
player. The website is available in more than one language, so international players can view their results as
well.

The Internet is also a great tool for the tournament management; because it is possible have an online entry!
These entries can be downloaded in the Tournament Planner by only one click on a button. This means no
more typing!

Publishing your tournament

To publish your tournament online select Internet -> Publish from the main menu.

If you are ready filling in the data you can publish your tournament. First make sure you have a connection
with the Internet and then click Publish this can take a few minutes. Your tournament is now published on the
website. You can see the progress in the log window on the General tab.

If there are changes in your tournament or new results are entered you can simply press Publish again and
the tournament on the website is made up-to-date.

You can easily create a link from your own homepage or website to your tournament on our website. First you
have to search your tournament on the website with the help of one of the search options. You can now use the
Internet address from the address bar of the Internet Browser as a link. This link will look like:
http://www.tournamentsoftware.com/sport/tournament.asp?id=xxxx where xxxx is the unique code for your
tournament. This code will not change when publishing again.
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General tab

Tournament Online
tournament
software

General | Online Entry | Events | Regulations | Availability | Payments
Show scheduled matches: 7 Until Sun 22/03/2015 W
Show Flags [ ]show State [ ]show Club
Message:
Task Status
Publish Close

Use the field Show scheduled matches to select which scheduled matches you want to show on the internet.
If you run an international tournament you can check the option Show flags. The national flag of the player
will be displayed online. If you also want to display the state and club you can tick Show State and Show
Club. To inform players and spectators with the latest news, you can use the Message window. The message
will be published online on the first tab of the tournament.
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Online Entry tab

Tournament Online
tournament
software

General | Online Entry | Events | Regulations | Availability | Payments
Online Entry: | On W
Member ID required
Show extra items on entry form
Start entry date: |20,02/2015 E~ Time: |00:00
Final entry date: |24/02/2015 [E~- Time: |23:59
Withdrawal date: |24/02/2015 E Time: |23:59
Max total events per player: |3 ]
Max singles per player: |2 W
Max doubles per player: |2 (¥
Max mixed per player: |2 ]
Publish Close

If you want to enable online entry you can tick Enable online entry. Enter a Final Entry Date after the
current date. If this date is on or before the current date online entry is disabled on the website. If you tick
Member ID required, players cannot enter online without specifying their member ID. If you tick Entry
with account mandatory, only the players with an account can enter the tournament.

Check Show extra items on entry form to make the extra items visible for players entering online. You can
set the extra items on the tournament properties screen. This could be a banquet or a T-shirt.

In the field Max total events per player you can set up the maximum number of events a player is allowed
to enter. You can also do this for single, double and mixed events.
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Events tab

Tournament Online

tournament
software

| General | Online Entry | Events | Regulations | Availability I Payments |

Please check the events players may enter online.

Event

] B ms
] B ws
[ 9 M
[v] B wp

On the Events tab you can select which events can be entered online. Default all events are ticked. If a
certain event is full you can untick the box and publish your tournament again.
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Regulations tab

Tournament Online
v tournament
software

| General | Online Entry | Events | Regulations | Availability | Payments |

Load Text

If you wish to publish the rules of your tournament you can enter or copy/paste them on the Regulations tab.
You can do this from a word processor or load them by clicking the button Load text. If a player wants to
register he or she has to accept the rules first.
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Availability tab

Tournament Online
v tournament
software

| General | Online Entry I Events | Regulations | Availability |Pa1fmer1ts|

Double did: any day to change the settings.

Day Availability Start End
FMon 16/03/2015 Yes 12:00 22:00
ETue 17/03/2015 Yes 12:00 22:00
Jwed 18/03/2015 Yes 12:00 22:00
[]Thu 19/03/2015 Yes 12:00 22:00
[Fri 20/03/2015 Yes 12:00 22:00
[sat 21/03/2015 Mo

[sun 22j03/2015 Mo

Max days not available:

On the Availability tab you can set the days the players are allowed to enter their availability online. At Max
days not available you can set how many days a player can be unavailable.

Double click a day to change the settings:
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General

Day Properties

Sat 1/10/2015

Flayer can spedfy availability

P Vil Reality

Start: 07:00 v
End: 00:00 vl
= L= |
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Payments tab

Tournament Online
v tournament
software

| General | Online Entry I Events | Regulations | Availability | Payments |

Online Payments Method: |Nune W |
Online Payments: |Required W |
Currency: |Dﬂ1er ~ |

Paypal Email Account: | |

Paypal Certificate Code: | |

Flease dick here to visit our website for more information on how to

@ In order to use online payments you must have a valid Paypal account.
setup online payments.

On the Online Payments tab you can select if you want to activate online payment with paypal for your online
entries.

For more information about how to setup your paypal account, please visit the online tutorial:
How do I setup online payment with paypal for online entries
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Online Entry

If you have filled in a Final Entry Date after the current date it is possible to register online. If you want to
check if there are online entries available for your tournament then select Internet->Entries...

Tournament Online

Internet Entries
Click next to pick up your entries,

This wizard will help you pickup entries from the internet.

You can select which entries you want to add to your tournament.
If the events of an anline entry are different from the same player in your
tournament it will show up in red.

Click next to continue.

< Back Cancel Help

If you click Next, the Tournament Planner will check if there are online entries available on the web server.
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Pickup tab

Tournament Online

Downloading Entries
Please wait while your entries are picked up.
Click next to view your entries,

Log:

JCunnecﬁng to server

JRetreiuing entries (This may take several minutes)

JS? entries on the server

q,d'?)4 new players added, 15 players already in the tournament, 0 deleted players, 1 withdrawn
v’?)Connection ended

< Back Cancel Help

You can check the progress in the log window. This way you can download up to 500 entries in only one
minute, without any typing! If the download is finished, all the online entries will be displayed in a list.
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Entries tab

Tournament Online

Select Entries
Please check the players you want to add to your tournament. Players in red already
exist in your tournament with other events.

Mew | Existing | Deleted | Withdrawn

Mame Member ID Events G DOB Club Co..
i L.T.V. Vormer MED
: TVDeHoef  MED
TOZ NED
i De Witte 5... NED
[tc de brug MED
3 OLTC 055 NED
T.N.DeBr... NED
LTC Rackets ~ MED

< Back Cancel Help

All the entries are displayed in a list. The entries are separated under three tabs: New, Existing, Deleted and
Withdrawn.

If a player is already in your tournament but the online events differ from the events in your tournament then
the player will be indicated in red. You can decide yourself if you want to add this player.

Click Finish to continue importing the players.
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Print tab

Tournament Online

Print
Please select the entries you want to print.

Print Entries

(@) All online entries
i) &ll new entries

[ ]1 page per player
Print

< Back Close Cance Help

Finally you have the option to print entry forms. You can print:
e All online entries
Print all the downloaded entries.
e Selection only
Print only the new entries.

Place a check in 1 page per player to print only 1 player on each page. Click Print to start the printing.

Generate HTML

If you choose not to make use of our website it is possible to generate HTML pages with the Tournament
Planner. You will have to upload the pages to your homepage or website yourself. This requires some
knowledge of the Internet and the use of an FTP program. Select Internet->Generate HTML from the main
menu to generate the HTML pages.
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Generate HTML

General

Folder: Browse

Picture: Browse

Backaround color:

Text color: -

Show scheduled matches: Al W

QK Cancel

At Background color you can select a background color for the HTML pages. If you rather have an illustration

as a background you can select this one at Picture. Click on E] to select a picture. The text color can be
select at Text color.

The following pages are generated:
e An overview of all matches per day.
e An overview of all draws.

In this case it is not possible to select players in draws and have statistics per player. This is only possible on
our website because all the pages are generated on the fly.
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Reporting

With the Tournament Planner you can print all sorts of documents and overviews. In this chapter they are
described one by one. Many reports start in a preview mode so you can see what you are about to print.

: : - o
L7 Print Preview
JEW|AL|I0O000 SRCRCNLREIN]

Demo Tournament
Marfcfes of Mondey 3/ 16/ 3015
Cats Oy, Conriy Walte
1&-22 Mar 3015 Ak maar, NED
Time= Ew=nit HWr Court Loctin Round T=aml T=am 2 Soore

Dur. Umgir= Start Rnish
SO0 MS-Grouos =1 Irsice REL Patrick RoocS]  Joimi Gmes[ 5]

o2 @ vanlem SIEZAM
SO0EM ME-GropE #: z Irsice REL Joos Sena] 1] AogerDasgerd]

o= @ vanlem 33TPM
SO0 MS-GroapC =1 3 Irgice RRL Sk Harear 11]  Herk Schoeten4]

SEIAM

SO0 MS-GowoD =4 Irsice REL Richan SauerZ] Miched oe Wrieg )

o= SIEZAM
L0CES AM MO == Qs RFZ Dot GmoasMiche ca Wriss[4] S Bolker+Ridhenc SooeE)
L0730 AM ME-Group & 2 Irgics: REZ Shmemn Boked 1] Patrick FooclE]
1130 &M ME-GrounE = Irsicie RFEZ Dilk wan d= Velden[3] Jors Sene] 1] &L I-6[ -5

LS
11730 &M ME- Group T = Irsice D Fuir Famps(lE] Bk Harpe1l]
L1730 AM ME - Grop D 2 Irgics: REZ MarcHosimersT]  Fidhend Sausr]
ZO0O0PM MS-Groa s == Irsice REE SevenBoe ] JomiGmes]E]
IO0FPM ME-GropoE = Irsice REE Thrvan oe Veiger(S]  FogerDesgerd]
ZO0PM ME-GrapC = Irgics: REE Fur el Z]  Herk Schouben4]
ZO0PM MS-GawoD == Irsice REE MarcHosrrralT]  Midel oe e 5
A D OUNMAMEtsoftwa r= Com

Pagel FFIIEZEILM Terrts Touramert Pemer

0% | Pagelofl

In the Print Preview you can print, zoom in and out, or select another printer. Some reports can also be
exported to Excel, Word, HTML or CSV. The export will not work on all reports.
Several reports also have the option to select players before you print the report. You can find the explanation

for the player selection at Working with the Tournament Planner -> Selecting Players.
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Matches
Print matches

You can print an overview of the matches for each day. In case of played matches the winner and the result
are printed bold. Select Report -> Matches -> Matches from the main menu to print the matches.

Print Matches
Select Days Select Fields
Day Field
(] Fsat 1/3/2015 Time
[ ] Elsun 1/4/2015 Event
[] Fsat 1/10/2015 N
] Edsun 1/11/2015 Court
Location
Found
Team 1
Team 2
Scaore
Duration
Umpire
Start
Finizh
Time: (00:00) to 23:59 All Maone
Location: <Al W
Order: | Time v Extra:  <Mone:x W

Print Excel Close

Select the day you want to print the matches of. You can check the fields you want to print. Click All to check
all fields and click None to uncheck all. If you want to print the matches for a specific location you can use the
Location filter. At Extra you can select what additional information you want to show with each player.

At Order you can set the order of the printed list. Click on Preview to view the result, Excel will export the
selected information directly and Close closes the window.

Print match forms

You can print the match forms for a certain day, location and time. You can use this overview if you want to
keep the computer with the Tournament Planner and the match forms separated. You can then fill in all scores
on the match form and enter them in the Tournament Planner on a later point of time. Select Report-
>Matches->Match forms from the main menu.

4 Vinal Reality 152



Match Form

Day

[sat 1/3/2015
Fsun 1/4/2015
Esat 1/10/2015
Esun 1112015

Time : |(00:00| +to 2359

Location: <Al = W

Order: | Time W

You can select the day and a time period. Click OK to print the overview.

Match Cards

You can print match cards of all the matches of a certain day, time and location. You can give these match
cards to the playing teams. The results can be filled in on these cards and later entered in the Tournament
Planner. Select Report -> Matches -> Match Cards from the main menu.
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Match Cards

Day

Esat 1/3/2015
Esun 1/4/2015
Fsat 1/10/2015
Esun 1/11/2015
Empty Match Cards

Time : (00:00) to [23:59

Location: Al Y]

Court Schedule

You can print a matrix of all the matches per day. This will give you an instant insight in the usage of each
court. Select Report -> Matches -> Court Schedule from the main menu.
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Court Schedule

Day

[ ] [sat 1/3/2015
[ | Edsun 1/4/2015
[ ] [sat 1/10/2015
(] Esun 1/11/2015

oK | | Cancel
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Match Signs

You can print an overview of Match Signs. Select Report -> Matches -> Match Signs from the main menu.

Match Signs

Day

[sat 1/3/2015
Fsun 1/4/2015
Esat 1/10/2015
Esun 1112015

Time : |00:00 to 23:59

Skip if not all players are known

Location: <Al W

Export Press Results

You can print an overview of the Press Results. Select Report -> Matches -> Export Press Results from
the main menu.
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Press Results

Day

Fsat 1/3/2015
Esun 1/4/2015
[sat 1/10,/2015
fsun 1/11/2015

Mames: | Full name v

Extra: | Country W

Print Match Notes

To print all the match notes select Report -> Matches -> Match Notes from the main menu.
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Alphabetical List

To print the Alphabetical List select Report -> Matches -> Alphabetical List from the main menu.

Alphabetical List

Day

sat 1/3/2015
Esun 1/4/2015
sat 1/10/2015
sun 1/11/2015

Location: <Al = W

Show Location

Header:
Released: | 7f 82014 w | |[10:26:54 AN | | Mow

Show: | ] all players on selected day v
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Sign In

Select Report -> Matches -> Sign In. You can select a day. All the players who have a match on the
selected day will be printed together with a space for them to sign.

Sign In

Day

Esat 1/3/2015
[sun 1/4/2015
[sat 1/10/2015
fsun 1/11/2015

Location: ZAll= W
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Scoresheets

You can print score sheets of all the matches per day and per location. Select Report -> Matches ->
Scoresheets from the main menu.

Scoresheets

Day

Esat 1/3/2015
Esun 1/4/2015
Fsat 1/10/2015
Esun 1/11/2015

Time ¢ |00:00 to 23:59
Location: <Al = W
Order: | Time LY

Skip if not all players are known
Skip if already printed

Show: |Country W

Event: | <All= W

Blank Scoresheet

Prints a blank score sheet. Select Report -> Matches -> Blank Scoresheet from the main menu.
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Draws
Print draws

To print the draws select Report -> Print Draws from the main menu.

Print Draws

Double dick any draw to preview and adjust settings

Draws | Options

Drraw Stage  Zoom Fit To Page Center Orientation  Modified
MS - Group A 1 100 Mo Mo Portrait Yes
MS - Group B 1 100 Mo Mo Partrait Yes
M5 2 100 Mo Mo Portrait Yes
W5 1 100 Mo Mo Portrait Yes
|:| MD 1 100 Mo Mo Portrait Mo
|:| WD 1 100 Mo Mo Portrait Mo
All Mone Settings

Check the draws you want to print. Click All to check all the draws, click None to remove all the checks. At
Printer you can select a printer. Place a check in Print Color to use the same colors as your screen. You can
uncheck the box Show Scheduled Matches to hide the scheduled times in your draws when printing.

You can set up the print setting per draw. Select the draw and click Settings.
On the settings tab you can specify the general print settings.
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Print Draws

Double dick any draw to preview and adjust settings

Draws | Options

Show scheduled matches: All W
Print color

Print draws in same stage together

Elimination draws

(®) Print scaled
|Ise this option to print the draws exactly as they appear on your screen, You can set the scaling of each
draw.

i) Print in sections
Chedk this option to print the draws in sections of 8, 16, 32 or 64.
Max lines per page for singles: 64 W

Max lines per page for doubles: 32 W

Printer PrimoPDF Cancel

You can select if you want to show the scheduled matches in the draw when printing. You can also select to
show until a specified day of the tournament.

Place a check in Print Color to use the same colors as your screen.

You can print draws of the same event and group on a single page if it fits. Check Print draws in the same
group together to enable this feature. This makes it possible to print an elimination draw and the playoff on a
single page or print a couple of qualification round robins on one page.

When printing elimination draws you have 2 options:

e Print scaled: This option will print the draws exactly as they appear on your screen. You can specify setting
for each draw.

o Print in sections: Each elimination draw will be printed in neat sections of 8, 16, 32 or 64 lines per page.
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Page Setup

1/ Page Setup

[ ]center ToPage [ _|Fit To Page 100 w oy [+ | - | Orientation: |Portrait Y

Demo Tournament

MS - Group B
T 7318 1
Tt TermoToumamoiPlomer e Tou maronlad Dware. mm
Vambwio L 5t |deg 1 z ] +
L] B ricad zak ki =
R __ o] = 2 =
. ? = B = - az

=

L pichd Zok Al
L chct Anard
L Kevin AW
L Michad Dokder

f

You can print draws centered, fit to page, portrait or landscape. You can also select a custom zoom and print
draws on multiple pages.
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Draw List

You can print a list of all the draws in the tournament. Select Report -> Draw List from the main menu.

Draw Standings

When you don’t want the print the full draws but just the standings of the round robins select Report -> Draw
Standings.

Round Robin Form

You can print a Round Robin Form. Select Report -> Draws -> Round Robin Form from the main menu.

Select Draw

Draw

L] Q‘] M3 - Group A
L] é‘] M5 - Group B
L &) ms

All Mone
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Round Robin Overview

You can print a Round Robin Overview. Select Report -> Draws -> Round Robin Overview from the main

menu.

Select Draw

Draw
O] E‘] M3 - Group A
Ol Q‘] M3 - Group B
Cl &) ms

all Mone
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Players
Players

You can print a list of all players that participate. Select Report -> Players -> Players from the main menu.

Select Players

|| | 0 players selected
Player Properties | Clubs | Countries | Events | Level | Days
] & Abdul, Mohd Zak v
L] 9 Adriyanti, Fird Ow
O 3 Ahsa, Muhammad omen
- g et Age From:
] a Anand, Chet
[l 9 Bae, Youn Joo Age To:
- P ErA——

r

] a Diekker - Michael [ ]Players without e-mail
x

L] a Dirksen, Johan
] a Jansen, Henk
] a Mee, Lu

[ ]Players with mobile
[ ]Players without mobile

] a Smith, Jonathan

] a Veldhof, Sebastizan
] a Vries, Dave de

1 & wit, Kevin de

All Mone

[ Manual entries
[ ]internet entries

[ ]Paid
[ Mot paid

Select
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Print Players

Select Fields

Field "

|:| M.

Mame
Firgtname
[ ] Middle name
[ ] Address

[ ] Address 2
[ ] address 3

[ ] Postal Code
(] city

[] state

[] country

[ ] Phone Home
[] Phone Work
[ ] Mobile

[ ] E-mail

[ ] ooe

[ ] Gender

[ ] Member 1D
[]ciub

[ ] District
[]sL

[]oL

|:| Rating 1

|:| Rating 2 W

All Mone

Order: Mame L

Preview Excel Close

You can check the fields you want to print. Click All to check all fields and click None to uncheck all. At Order
you can set the order of the printed list. Click on Preview to view the result, Excel will export the selected
information directly and Close closes the window.

First matches

If you are printing the first matches or exporting them to Dbase, you will get the message: ‘Would you like

to set the player status as warned for their first matches?’' This means you don't have to indicate per
player that he or she is warned. In this case the players get the warned color in the Matches view. This color
is default set to green.

Labels
You can print the first matches on labels. For every player two labels are printed:
e Label 1: The name of the player and his/her address
e Label 2: The name of the player with an overview of the first matches per event

Select Report -> First matches -> Labels from the main menu.
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Select Players

|| | 0 players selected

Player Properties | Clubs | Countries | Events | Level | Days
(] & abdul, Mohd Zak e

] 23 Adriyanti, Fird COw

] a Ahsa, Muhammad omen

= Eg A, Goto Age From:

] a Anand, Chet

] Eg Bae, Youn Joo Age To:

] Eg Baed, Seung

L] a Baekl, Shinda

L] a Dekker, Michael

] 3 Dirksen, Johan

] a Jansen, Henk

] a Mee, Lu

] a Smith, Jonathan

] a Veldhof, Sebastizan

[ ]Players with e-mail
[ ]Players without e-mail

[ ]Players with mobile
[ ]Players without mobile

[ Manual entries

[ ]internet entries
L] a Wries, Dave de
] a Wit, Kevin de [ ]Paid
[ Imot paid
All Mone Select Cancel

First Match Labels
Labels

Marme: |Avery Laser L7162 W

Details. .. Mew...

Sort
'l Mame

I PostalCode

The Tournament Planner offers you a couple of standardized sizes of labels. You can view the properties of
these labels by clicking Details, or you can add your own labels by clicking New. Sort by gives you the
opportunity to set the order of the labels to Name or Postal code.

List
You can print an overview of all first matches per event per player. Select Report -> First matches -> List
from the main menu.

Excel file (mail merge)

You can create a mail merge file of the first matches in Excel (*.xls) format. With an Excel file you can create
your own print out with the first matches. You can do this with the help of MS Word or another word processor.
Select Report -> First matches -> Excel file (mail merge) from the main menu.

Email
You can send the first matches to the players by email. Select Report -> First matches -> Email
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First Match E-mail

E-mail

Subject:

Dermo Tournament

Header:

Here comes the event and first matches of the player
Show court
Footer:

Cancel

You can enter a Subject. Default the Subject has the tournament name filled in, but of course this can be
changed. The message is divided in to three parts, a header, the first matches of the player and a footer. You
can enter the header and footer, the Tournament Planner generates the first matches automatically. If you are
ready click Send to send the message.

Payments

You can print an overview of all players that haven't paid the fee yet.

[ Attention: Players who do not have to pay will not appear in the list. If no fee is filled in for an event, the
players don’t have to pay and therefore will not appear in the list. You can change the fee in the Tournament
Properties.

Labels

For all players that haven’t paid yet you can print a label. The name of the player, the amount of money that
still has to be paid and the registered events are printed. Select Report -> Players -> Payments -> Labels
from the main menu.
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Payment Labels

Labels
Mame: |Avery Laser L7162 W

Details. .. Mew...

The Tournament Planner offers you a couple of standardized sizes of labels. You can view the properties of
these labels by clicking Details, or you can add your own labels by clicking New.

List
You can print a list of all players that haven’t paid yet. The personal data, the amount of money that still has to
be paid and the registered events are printed. Select Report -> Payments -> List from the main menu.

Payment Details
You can print a detailed list of all the payments. Select Report --> Players --> Payment Details

Receipts
You can also print a receipt for every player. Select Report -> Players --> Payments -> Receipts from the

main menu.
Receipts

[ ]1 player per page
[ ] 5ort collating

You can now check the players you want to print a receipt for. Click All on to check all players and click None
to remove all the checks. If you check 1 player per page you will get a separate page per player.
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Player matches

You can print an overview of all planned matches per player. Select Report -> Players -> Player matches
from the main menu.

Select Players
|| | 0 players selected
Flayer Properties | Clubs | Countries | Events | Level | Days
[ § Abdul, Mohd Zak [ven
] Eg Adriyanti, Fird Cw
L] a Ahsa, Muhammad omen
D Eg Ai, Goto Age From:
L] a Anand, Chet
L] }23 Bae, Youn Joo Age To:
% % EEEE. z:{_mdg [ ]Players with e-mail
aekl, Shinda
] a Dekker, Michael [ |Players without e-mail
E a Dirksen, Johan [ Players with mobile
a Jansen, Henk [ Players without mobile
] a Mee, Lu
(] & smith, Jonathan [ IManual entries
E g Veldhof, Sebastiaan [ | nternet entries
Vries, Dave de
] 3 Wit, Kevin de [ Paid
[ ] Mot paid

all Mone Select Cancel

Player Matches

1 page per player
[ | set player status to warned
Skip players without matches

Indude address header

After selecting the players you have the following options:
e 1 page per player
Each player is printed on a separate page.
e Set player status to warned
The players will be automatically be marked as warned.
e Skip players without matches
Do not print players who have no scheduled matches.
e Include address header
Print complete letters, ready for the mail.

You can create a mail merge file of the players matches in Excel (*.xls) format. With an Excel file you can
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create your own print out with the matches. You can do this with the help of MS Word or another word
processor. Select Report -> Player Matches -> Excel file (mail merge) from the main menu.

You can send the matches to the players by email. Select Report -> Player Matches -> Email.
Not Warned

This will show you a list of players who still need to be warned for their matches. On this list the phone
numbers will also be printed.

Active Players

This report will show you all player that are still playing in your tournament. You can select the minimum
numbers of events for a player to show them on the list.

Active Players

Select the minimum number of events:

.

1

L

Player Elimination Status

You can print the Player Elimination Status. Select Report -> Players -> Players Elimination Status from
the main menu.
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Address Labels

You can print the addresses of players on labels. Select from the main menu Report -> Address Labels.

Address Labels

Labels
Mame: | Avery Laser L7162 W

Details. .. Mew...

The Tournament Planner offers you a couple of standardized sizes of labels. You can view the properties of
these labels by clicking Details, or you can add your own labels by clicking New.

Check players

The Tournament Planner gives you the opportunity to check the data of the players. Select Report -> Check
Players from the main menu.

Player Check

Address
Gender
Date of Birth
Member ID
Club
Singles Level
Doubles Level
Events
Max Events: |3 | =
Max Singles: |3 |

Max Doubles: |3

Max Mixed: |3

Email

You can select the options you want to be checked:
¢ Address
It is checked if the address is filled in.
¢ Gender
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It is checked if the gender is filled in.

Date of Birth

It is checked if the date of birth is filled in.

Member ID

It is checked if the member number is filled in and if it is valid.

Club

It is checked if the club is filled in.

Singles level

It is checked if the singles level is filled in.

Doubles level

It is checked if the doubles level is filled in.

Events

It is checked if there are players that are not participating in an event, if there are men that are
participating in a ladies event or visa versa. Or if there are two men or two ladies that are scheduled for
an mix doubles event or if there are incomplete teams. If needed there is a check for age and level.
Max Events

In the field Max Events you can set up the maximum number of events a player is allowed to
participate

Max Singles

In the field Max Singles you can set up the maximum number of Single events a player is allowed to
participate

Max Doubles

In the field Max Doubles you can set up the maximum number of double events a player is allowed to
participate

Max Mixed

In the field Max Mixed you can set up the maximum number of mixed events a player is allowed to
participate

Email

It is checked if the email address is filled in.
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Entries
Entries

You can print an overview of all players that are participating in an event. For every checked event you get a
list. Select Report -> Entries from the main menu.

Print Entries

Select Events Select Fields

Event Entries Field 2

] i M5 - Main Draw 12 Mame

] B WS - Main Draw 3 Gender

[ ] %MD - Main Draw 2 DOB

] B WD - Main Draw 3 Level
Rating
Ranking
Points
Member ID
Club
District
State
Country
Date

Phone Home
Phaone Wark
Mabile

Email

Seed

Status
Order

[ Mnte N

All Mone All Maone

Order: | Mame W Print Exccel Close

Now you can check the events you want to print. Click All to check all events and click None to remove all the
checks. At Order you can set up the order of the lists. The lists can be sorted by Name, Level, Club or
member ID. Click on Preview to view the results, click Print to print the results, Excel will export the
selected information directly.
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Entry Lists

You can print an overview of the sign-in lists, Report -> Entries -> Entry List.

Print Sign In Lists

Report Event
._:] Main Draw Roster B ms
[] oualifying Roster
(] Lucky Losers
[] rezerve List
[] Exdude Roster
Mr. of sign-in pages: |1 =
Sign-in Order: | Acceptance Ord v
Deadline:
7- 7-2014 13:00:00 =
Place:
Supervisor's Office
Print Excel Cloze
Entry Cards

To print the entry cards select Report -> Entries -> Entry Cards.

Partner Wanted

To show the list of players looking for a partner select Report -> Partner Wanted.

Seeding List

To show the list of seeds for each event select Report -> Seeding List.
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Tournament
Tournament Overview

The tournament overview shows per event the number of entries split in scheduled and not scheduled. This
overview also shows the number of matches, the number of played matches and the number of matches that
still have to be scheduled. Also you will see the number of sets, games, minutes and average minutes. Select
from Report -> Tournament Overview the main menu.

Notes

To print all the notes select Report -> Tournament -> Notes from the main menu.

Duration Statistics

When entering the match results you can also enter the match duration. The time statistics report will produce
an overview of durations per event and per round. Select Report -> Tournament -> Time Statistics from
the main menu.

Official Statistics

To print all the Official Statistics select Report -> Tournament -> Official Statistics from the main menu.

Match Status

You can print a list of all the walkovers, retirements and disqualifications. Select Report -> Tournament ->
Match Status from the main menu.

Print

Status

[] walkovers

[] Ret.
[ ] pis.
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You can select if you want to print the matches with walkover and/or retirement and/or disqualification.
Entry Status

To print all the Entry Statuses select Report -> Tournament -> Entry Status from the main menu.

Print

Status

|:| Direct Acceptance

[ ] wild card

[ ] Ludky Loser

[ ] qualifier

[ ] withdrawn

[ ] Qualifying Acceptance

Press overview

The press overview gives you a list of all the played matches per draw per event. You can use this list as a
handout for the press or use it in the club magazine. Select Report -> Press Overview from the main menu.

Winners

If you want to print an overview of the winners of every draw, then select Report -> Winners from the main
menu. The events are displayed in reverse order, so the highest category is last in the list. You can use this list
perfectly during the award ceremony.
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Winners

[ ]Print semi finalists
Print consolation winners

[ ]Print consclation runner-up

Showe: | Club W

You can select if you want to print other players besides the winner and runner up as well.

Players per club

To print a list of the participating clubs and the number of players, you can select Report -> Players per
club from the main menu. The clubs are displayed in alphabetical order.

Start and Finishing Times

Go to Report -> Tournament -> Start and Finishing Times to print a list of all starting and finishing times
from the tournament.
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Program settings

To change the settings of the Tournament Planner you select Extra -> Options from the main menu. Now you
can change the settings if you wish to restore the original settings click on Default.

General tab

Options

General | player Names | Match Colors | Scheduling | Internet

Default Tournament Folder: | C:\Users\<user =\DocumentsiTournaments Browse
Default Backup Folder: | C:\Users\<user =\Documents\Tournaments Browse
[ |Remember Height
[ |Remember Width
Date Farmat: |Day + Date W
Time Format: | Windows W

Country code: |31
Phone Prefix:

Phone Comport: |COM1 W

Default Cancel

On the General tab you can set up the following options:

e Default Tournament Folder
When you open a tournament or want to restore a backup this folder is shown first. This way you will not
need to browse to the correct folder to keep all your tournaments together.

o Default Back-up Folder
When you want to create a backup this folder is shown first.

¢ Remember Width and Height
If these options are checked the window size of the Tournament Planner is saved. The next time the
Tournament Planner is started the window size is set to the saved size. Otherwise the Tournament
Planner is started with default sizes.

o Date Format
You can set up the date format, there are three options: Day+Date (Wed 6-6-2015), only the Date (6-
6-2015) or just the Day (Wed).

e Time Format
You can set up the time format, there are three options: Windows (time configuration in windows),
14:30 or 02:30 pm.

¢ Country code
If you fill in the country code, you don't have to do this for every number separately.

¢ Phone Prefix
If a prefix is needed for dialing phone numbers you can enter it here.

¢ Phone Comport
You can set up the communication-port (COM-port) of your modem, needed to dial the players phone
number.
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Player names tab

Options

Order

() Lastname, Firstname

(®) Firstname LastMame

Last Mame
i) Do not format

(®) Capitalize first letter
() CAPTTALIZE

First Mame
i) Do not format

{®) Capitalize first letter
() CAPTTALIZE

Default Cancel

On the Player Names tab you can set the display format for the player names on draws and match lists.
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Match colors tab

On the Match colors tab you can set up the colors that are used for displaying the status of a player (warned,
checked-in, paid, etc.) in the matches view.

Options
General | Player Names | Match Colors | scheduling | Internet

Draw line between match times
Use colors in match overview
Show flags in match overview

Mormal Selected
Player on court AaBb
Player not warned AaBb W
Player warned AaBb w
Player checked in AaBb

Flayer did not pay —

Default Cancel

The option Draw line between matches will clearly group matches together starting at the same time.

You can switch the country flags on the macthes pane on and off using the option Show flags in match
overview.

If you are not using the status colors of a player, you can turn off the option Use colors in match overview.
You can set up colors for:

Player not warned

Player warned

Player checked in

Player did not pay

Per status you can set up the normal and the selected color.
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Scheduling tab

On the Scheduling tab you can set up Remember rest-time and Remember maximum matches per

day.
Options

General | Player Names | Match Colors | Scheduling | Internet

Remember maximum matches
Per day: |3 =

Per event per day: |2 =

Singles per day: |2 =

Chedk if next match is scheduled

Default Cancel

You can set up the default rest periods for elimination draws and for round robins separately. You can also
enter the default number of maximum matches per day, per event per day and singles per day.

3 Vinal Realily 183



Internet tab

When you need a proxy server to connect to the internet, you can specify the settings here. When you still
have problems connecting to the internet, check for firewalls or virus scanners which may block the access..

Options

General | Player Mames | Match Colors | Scheduling | Internet
Proxy Server

[ |Use a proxy server

Email

From email address:
Cutgoing mail (SMTR): Port:

[ ] This server requires an encrypted connection (S5L) Help

|:| My server requires authentication

Default Cancel

To use a proxy server check the box. Fill in the proxy Address and the Port number. These settings are used
when publishing your tournament and when picking up entries.
In order to send messages from the Tournament Planner you need to specify your e-mail settings.

Fill in your own e-mail address in From e-mail address. This address will be used as sender when creating
e-mail messages. Specify your outgoing mail server in Outgoing Mail (SMTP). You can copy these settings

from the settings in the program you use to send e-mail. You can also find it in the manual of your internet
provider.

In the new version it is also possible to use the SMTP from Hotmail, AOL or Gmail. Click on Help to open the
online tutorial how to set it up.

If your outgoing mail server needs authentication you can specify your account name and password.
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Tournament TV

Tournament TV

General | Draws

Automatic Update Test
Scheduled Matches

Maximum #: |30 = From (00:00 | To |23:59

Finished Matches
Maximum Z: |30 = From |00:00 | Tgo |23:59

Location: <All= W

Port: (13333

IF Address: P

192, 1638.2,100

Add Delete

Close

Tournament TV is an application similar to Powerpoint, which allows you to inform the players and the audience
about upcoming matches, current matches and results. Besides the match information you can add your own
text pages, photo's and sponsors. All the match information is automatically updates from the Tournament
Planner

At Scheduled Matches and Finished Matches specify the number of matches.

At Location you can select the location you want to display on Tournament TV.

If necessary you can change the Port number. If you change the default port number you also have to do this
in Tournament TV.

At IP-adres specify the network addresses of the computers running Tournament TV.

Click on Test to check if the Tournament TV computer can receive data from the Tournament Planner.

Errar

,"’. .‘", The data could not be delivered to the following 1P(s):
W 192 ,168,2,100

Above error message means that Tournament TV does not receive data:
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1.1t is possible that your firewall is blocking the connection. You can temporarily disable your firewall, or
configure it that the Tournament Planner can send data over the network to the Tournament TV computer.
The traffic is on port 13333 (default) over UDP protocol.

2.The first four numbers of the the version number must be the same of both products. You can check this in
the main menu Help -> About.

About Tennis Tournament Planner

/ Tournament Planner

Version 2015, 1 (Build 04-Jan-2015 16:37)
Copyright © 1993 - 2015 Visual Reality

') tournament

On the Draws tab you can tick the draws you want to display on Tournament TV.
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Tournament TV

General | Draws

Draw

MS—GruupA
MS—GruupE
MS-GruupC
MS—GruupD
][] ms
¥ [ mD

All | | Mone
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Appendix

The toolbar
m Ctrl-N New Tournament Create a new tournament.
m Ctr-O  Open Tournament Open an existing tournament.
m Ctrl-S Backup Tournament Backup the current tournament.
lﬂ Restore Tournament Restore a backup.
m Tournament Properties Open the tournament properties.
m Print Print the current screen.
IE‘ Add Player Add a new player.
IE‘ Delete Player Delete the selected player.
IE‘ F9 Find player in draw Locate a player in the draws.
@ F10 Matches of player Show all matches of a player.
3 Add Draw Add a draw sheet.
= Delete Draw Delete the selected draw sheet.
m Add Note Add a note.
I__;‘ Delete Note Delete the selected note.
l;‘ Entry Properties Open the properties of the selected entry.
g Automatic Seeding Open the automatic seeding dialog.
A Make Draws Open the Draw Wizard.
‘| Enter Select Entry Select an entry and place in a draw manually.
3 Schedule Tournament Open the automatic Scheduling Wizard.
m Schedule Round Schedule a round of an event.
m F7 Schedule Match Schedule a match manually.
m Del Clear Match Remove the scheduling or remove entry from draw.
@i Del Delete Entry Delete the selected entry.
l_‘ F6 Show Match Locate the match in the matches view.
lﬁ‘ Enter Match Properties Open the match properties.
m Print Draws Print one or more draws.
m Match to Court Assign the match to a court.
@ Free Court Free the court.
m F6 Show Draw Locate the match in the draws.
l_‘ CTRL-F Find Find players in the match overview.
l_v‘ Publish Tournament Publish the tournament to the Internet.
& Pickup Entries Pickup entries from the Internet.
m Generate HTML Generate HTML pages for your homepage or website.
Ij‘ Send Messages Send all messages.
m Options Open the Program Settings.
lﬂ F12 Change Partner Change the partner of an entry in a doubles event.
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The main menu

Tournament

Plaver

Draw

Report

New... lj'

Open...
Close

Restore T
Properties...

Income and Expense
Exit

Add Player

Delete Player
Find In

Find In Draw

Show Matches

Send Email

Send SMS

Copy To Player Database
Pickup From Player Database...
Import to Player Database...
Export Player Database
Import Entries...

Import Ranking...

Import Clubs

Export Clubs

Print Draws...
Make Draws...

Schedule Tournament...

Clear Draws...
Conflicts...
Check Rest Time

Links...
Adjust Standings...
Add Draw

Delete Draw

0

i

g

D[]

2k

[

[E[5

=

TLE

Draw Location

Calculate...

Layout...
Export to Excel

Matches
Matches...

Matches Per Location...
Match Form...
Match Cards...

Court Schedule...

mvwi Reality

&

Ctri-N

[ 2] ctri-0
Backup ITI_I

1| Ctrl-S

F8

F9

F10

F3

F11

Create a new tournament.
Open an existing tournament.

Close the current tournament.
Backup the current tournament.

Restore a backup.

Open the tournament properties.

The income and expense of the tournament.
Close the Tournament Planner.

Add a new player.

Delete the selected player.

Locate a player in the roster.

Locate a player in the draws.
Show all matches of a player.

Sending an email to a selected player.
Sending an SMS to a selected player

Copy all the players to the player database.
Pickup players from the player database.
Import players in to the player database.
Export the player database.

Import players directly into the tournament.
Import ranking from an Excel file

Import clubs from an Excel file

Export clubs to an Excel file

Print one or more draws.
Open the Draw Wizard.

Open the automatic Scheduling Wizard.

Clear one of more draws.
An overview of conflicts in match planning.
An overview of the rest times.

View/edit the links between draws.
Adjust the round robin standings.
Add a draw sheet.

Delete the selected draw sheet.

Linking a draw to a location.

Calculate the number of matches and create
draws based on entries.

Change the layout of multiple draws.

Export the draws to Excel.

Print the matches per day.

Print matches per location.

Print the match forms.

Print the match cards.

Print an overview of the courts with the
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Export Press Results...

Match Notes
Sian In
ScoreSheets...

Blank Scoresheet...

First Matches
Labels
List
Dbase File
E-mail
SMS

Player Matches
Print
E-mail
Dbase File

Not Warned

Active Plavers...
Payments

Labels

List

Receipts
Address Labels

Players...

Check Players...
Entries...

Entry Cards...
Partner Wanted

Seeding List
Match Notes

Notes

Print Draws...

Draw Standings...
Draw List

Court Schedule...

Tournament Overview
Duration Statistics
Walkovers

Press Overview

Winners
Plavers Per Club

Internet

Publish...

Entries...

Generate HTML...

Messages

Send Players Email
Send Players SMS

Send All...
Pickup Confirmations

mvwi Reality

=] Be]

4]

§

&sl¥]

=g

i=L] [

planned matches.
Export the press results for a selected day.

Print the match notes.

Print sian in sheet.
Print score sheets.

Print a blank score sheet.

Print the first matches on labels.
Print the first matches as a list.

Export the first matches to a Dbase file.
Email the first matchers.

SMS the first matches

Print the matches for one or more plavers.
E-mail the matches for one or more plavers.
Export the player matches to a Dbase file.
Print a list of the players with status not
warned.

Print a list of the still active plavers.

Print payments on labels.
Print payments as a list.

Print receipts.
Print addresses on labels.

Print a player list.
Check the player data.

Print the entries as a list per event.
Print the entry cards

Print a list of the players with a Partner
Wanted status.

Print a list with de seeded players.
Print all match notes.

Print all notes.

Print one or more draws.

Print all the draw standings.

Print a list of the draws per event.

Print an overview of the courts with the
planned matches.

Print a tournament overview.

Duration statistics of the played matches.
Print a list with the matches with a walkover.
Print a press overview.

Print a list of the winners.

Print a list with the players per club.

Publish the tournament to the Internet.

Download the online entries from the web
server.

Generate HTML pages for your homepage or
website.

Send email to one or more players.
Send SMS to one or more players.
Send all messages

Pickup message confirmations
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Extra

Help

Delete

Led Display...
Tournament TV

Options...

Contents

Internet Site

System Info...
Check for updates...

About Tournament Planner

cle] Lo

O]

n
[

Delete selected messages.

Configure the led display.

Configure Tournament TV.

Configure the Program Settings.

Open the help system.
Go to the product website.

Get the system info.
Start the auto update
About the Tournament Planner.
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The Tournament Planner and foreign currency

In the European Union everybody is using the Euro. No problem for the Tournament Planner! The Tournament
Planner uses the currency selected in windows. In fact the Tournament Planner can be used with any currency.
You can set the currency in the Control Panel. Select from the start menu Settings -> Control Panel. Then
open the Regional Options and go to the Currency tab.

= | Customize Format

Mumbers | CUrrency |Time | Date

Exarnple

Positive: | €123,456,785.00 Megative: | (£123,456,789.00)
Currency symbol: € W
Positive currency format: £1.1 W
Megative currency format: £1.1) L
Decirnal symbol: . W
Mo. of digits after decimal: 2 v
Digit grouping symbaol: ] W
Cigit grouping: 123,456,729 W

Click Reset to restore the systemn default settings for Reset

nurmbers, currency, time, and date,

QK Cancel Apply

Now select your currency as Currency symbol and click OK to apply the settings. Your windows and
Tournament Planner are now configured to use the new currency.
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Tutorials

Here you can find tutorials for the Tournament Planner.

Tournament on more then one location

When a tournament is held on several locations you can indicate this in the tournament properties. To do this
go the Courts tab and fill in the locations.

F

Tournament Properties

| Info I Events | Days | Times | Courts |F‘.uund Robins I Entry Fees | Drawsl DF’ﬁciaIs|

Courts Locations

Court Location Location

Edit Edit

Delete Delete

IEE | g

Mawve Lp

Mawe Dawn

[ Cancel

o
-~

In our example the tournament is held on location A and B. Click right in the location area on Add to fill in the
locations.
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Locaticn Properties ﬁ
General

% Location A

ok || cancal || apply

i

Tournament Properties

| Info I Events | Days | Times | Courts |R.our1d Robins I Entry Fees | Drawsl DF’ﬁciaIs|

i

Courts Locations
Court Location Location
= ELoEﬁnn A |
it ELoEﬁnn B
Delete Delete

Mave Up

Mawe Down

ok || cancel

When the locations have been added it's time to fill in the courts and link them to a location. In our example
location A and B have both two courts. Click in the courts area on Add to fill in the courts. In the General tab
you can give the court a name and link it to a location:
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Court Properties u
General | Availability

=l
=l 1
Location: iﬁ ﬁw i - i

=Mone >

: Location A
¥ Locatoin B

[2)e) [oc J[ corcel J[ somr

It can occur that a court is not available the entire day. In the tab Availability you can fill in for every court
when it's available and when it's not. In our example the court isn't available between 12 PM and 3 PM because
of maintenance. The hindrance will automatically taken along when scheduling the tournament.
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F

i

Court Properties

Availability

15 SCID ¥ Not available Copy from
[ e el e T s o s s s o o T B e
(T R R 8 R R R IR I I v R T R
Scoooocococococoooooob
o D s T s T o U s R s R e o s T s s R e o S o s Y s |
I = @ = O 0O O O m o o o o 3
ZTEZEEZEZEEZEZEEE=ZIDZIDZEEE

wo 6-6-2007 D

do 7-6-2007

vr 8-6-2007

za 9-6-2007

z0 10-6-2007

ma 11-6-2007

di 12-6-2007

wo 13-6-2007

=) o ) [cmm J[_oom

When all courts have been linked to a location you are ready in the Courts tab.

i

Tournament Properties

| Info I Events | Days | Times | Courts |R.our1d Robins I Entry Fees | Drawsl DF’ﬁciaIs|

|t
Locaton

Courts Locations
Court Location
|E] 1 Location A ELoEﬁnn A Edit
) Edit . :
|E] 2 Location A ELoEtmn B
E Locatoin B = Delete
e Locatoin B

Mave Up

Mawe Down

ok || cancel

Draw location
Select from the main menu Draw -> Draw Location. Here you can indicate on which location a draw is
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played. You can select left the draw and select right the location. Press on to link them to each other.
If you now schedule the draw all matches will be automatically scheduled on the linked location. It's always
possible to make changes and schedule matches manually on a different location.

r =~

Draw Location

Draw Location Court Location

[F] Ms - 3 - Blimination 1

il o< |
FAmo-3

Court
<All Courts =

B
E =2

Coc ] Lo

Scheduling
You can now continue with scheduling like you normally do.

In practice
When the tournament is set up you need to make a backup of the tournament for every location.

-
ﬁ' Tennis Tournament Planner - Demao Toernooi

Tournament | Player Draw Report  Internet  Messages Extra  Help
1 New.. Ctrl+N 2888

- DOpen... Ctrl+C ]
|

Close Ctrl+F4

B Backup... Ctrl+5
i

Restore...

rt Usage | Statistics |

ournament Planner

Import Results...

“r Properties...

Every location works with a backup of the original tournament file and only processes the results for that

location.
On an arranged moment the different locations email their tournament file with the processed results to the

tournament director. The tournament director can now import the results into the original tournament file:
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r

@ Tennis Tournament Planner - Demo Toernooi

Tournament | Player Draw Report  Interne
1 New.. crisN || @ 8 8§
4 Open.. Ctrl+0 |
i
Close Ctrl+F4
rt Usage | Statis
?_J Backup... Ctrl+5
%‘ Restore...
Irnport Results...
7 Properties...
Inceme and Expense... mool
Exit
e Pk a Task
& Setyour tournament pro
3}1 * Add players to your toun

Browse to the emailed tournament file and click on finish. You need to repeat this action for every location.

Import Results ﬁ

File

-
Select the file to import from ? ‘.

Browse

If you are running your tournament at multiple locations you can use a copy
of the tournament file at each location. The results and payments can be
imported back into the ariginal file,

Import Results
Results will only be imported if the draw has not been altered.

Import Payments

Details of player payments will only be imported where the amount paid
for a player has increased. IE no refunds should be dealt with on a
secondary file.

< Back Finish Cancel ] ’ Help

When every location is imported into the original tournament file the tournament is up to date. For the second
play round you need to repeat the above described actions starting with making a backup for every location.
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Index Draws Settings 34

Drawsheet 102, 103, 104, 105

-A- Drawsheets 106, 111, 117, 120, 121, 161, 163
Duration 177, 178

Active Players 172 Duration Statistics 177, 178

add official 37 - E _

Address 19, 57, 173
Automatic 83, 101, 102, 103, 104, 105, 106, 107,  Elimination ~ 88

108 Email 55, 135, 136, 137
Auto-Update 7 Entries 78, 85, 86, 87, 175, 176
Availability 25, 60, 143 Entry 80, 81, 83, 106, 146, 147, 148, 149
-B- Entry Cards 176

Euro 192
Backup 11,12, 14 Event 101, 102, 103, 104, 105
- C - Event Fee 32

Events 20, 59
Eventstab 70
Expense 39
Export 77,78
Extra columns 97

Calculate 85, 86

calculate from availability per court 25
Calculation 85, 86, 87

Calculation Properties 87

Change partner 121

Check 173 -F-
Checkin 127 Fee 32
Clear 120 First matches 167
Club 50, 52, 54, 179 Flags 139, 140
Clubs tab 68, 69 format 35
Colors 182 Full Round Robin 88
Confirmation 136, 137
Consolation 84, 96, 99 -G-
Court 130 Group 88,95
Court Schedule 154, 156 -H-
Courts 25
Create link 117 Hardware 7
-D - Highlight 130

HTML 149
Date format 180 -1I-
Days 23
Daystab 72 Import 12,16, 17,72,73,74,77,78
dBase 72,73,74,77,78, 167 Import Ranking 66
Deleting Tournament 40 Income 39
District 50, 52, 54 Install 7
Draw 84,97, 99, 101, 102, 103, 104, 105, 106, 107, Installaton 7,8, 9
109, 117, 118, 122, 123 Internet 138, 139, 140, 141, 142, 143, 145, 146,
Draw Layout 123 147, 148, 149, 184
Draw List 164, 165 -L-
draw location 122, 193
Draw Standings 118, 164 Labels 167, 169, 173
Draw Wizard 88, 93, 94, 95, 96, 97, 98 Layout 97,123

Draws 85, 86, 87, 101, 109, 118, 120, 121, 122, ~ Leveltab 71
123, 161, 163 Link 117



Links
location
Locations
Logo 18

-M -

Mail Merge
Main Draw
Main Menu
Manual 106, 111

Match 107, 109, 111, 121, 124, 125, 127, 128, 129,
130, 152, 154, 156, 159, 160

Match Cards 153

Match Forms 152

Match Note 130

Match Notes 157, 158

Match Numbers 114, 115, 116

Matches 65, 85, 86, 87, 124, 125, 127, 128, 129,
130, 152, 153, 159, 171, 177, 182, 183

Member 72,73,74,77,78
Menu 188, 189
Messages 64, 135, 136, 137

Name 181

Newspaper 178

Not Warned 172

Note 63, 130, 157, 158
Notes 131, 177
Number 114, 115, 116
Numbers 114, 115, 116

-0 -

officials

Online
148, 149

Online Payments 145

Order of Play 132

Order Of Play Cell Properties
Order Of Play Properties 133
Overview 43, 45, 46, 48, 177

-P-

Page Setup 163

Partner 80, 81, 121
Partner Wanted 176
Payment 61

Payments 129, 145, 169
Phone 55

94, 95, 117
122, 193
25

167
95
189

12, 16, 37

134

Player 50, 72,73, 74,77, 78, 83, 127, 128, 129,
166, 169, 171, 172, 173, 176, 179

Player Database 72, 73,74, 77, 78

Player matches 65

Player names 180, 181

Players 49, 55, 56, 57, 58, 59, 60, 61, 63, 64, 65,
66, 67, 68, 69, 70, 71, 72, 172, 175, 176, 177
Playoff 84, 99
Poule 118
Press 178
Program Settings
Progressive draw 88

Properties tab 67

Publish 138, 139, 140, 141, 142, 143, 145

180, 181, 182, 183, 184

-Q-

Qualification 88, 93, 95

-R -

Ranking
Rating
Receipt
Register 9, 32, 146, 147, 148, 149
Regulations 141, 142

Report 152, 153, 154, 156, 157, 158, 159, 160, 161,
163, 164, 165, 166, 167, 169, 171, 172, 173, 175, 176,
177, 178, 179

58, 83
58, 83
129

Rest periods 183
Restore 12, 14
Result 124, 125
Roster 80, 81, 83, 84
Round 109

Round Robin 31, 88
Rules 141, 142

138, 139, 140, 141, 142, 143, 145, 146, 147, = § =

Schedule
Scheduling
Scheduling per round
Score 35, 125
Score sheet 160
Seed 83
Seeding 83, 176
Seeding List 176
Selecting Players
Settings 17, 86
several location
SignIn 159
SMS 56, 135, 136, 137
Software 7

12, 16, 106, 111, 120, 121
107, 108, 109
109

66, 67, 68, 69, 70, 71, 72
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Specify available courts manually 25
Standings 31

Start 11, 41

Statistics 177, 178

Status bar 41

System Requirements 7

-T-

Toolbar 188

Tournament 11, 12, 14, 16, 17, 39, 138, 139, 140,
141, 142, 143, 145, 177

Tournament properties 16, 18, 19, 20, 23, 24, 25,
31, 32, 34, 35
Tournament TV~ 185

tutorial 193

- U -

Update 7,8,9
Upgrade 7
Upgrading 8,9
- v -

Version 7
voorbeelden 193
- W -
Walkovers 177
Warn 128
Website 138, 146, 147, 148, 149
Windows 9

Winners 178
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